Bug 210585 - php-cli built without static readline support
php-cli built without static readline support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 18:45 EDT by Johannes Schlüter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.1.6-3.3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 12:41:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Schlüter 2006-10-12 18:45:19 EDT
Since PHP 5.1 PHP offers an interactive shell mode when run using "php -a" if
readline was compiled static into PHP. This mode won't work with readline as
dynamic module. So I would be happy having readline enabled by default for PHP CLI.

See my blog post for more information on that interactive mode:
http://blog.thinkphp.de/archives/44-More-PHP-power-on-the-command-line.html
Comment 1 Joe Orton 2006-11-15 07:20:25 EST
This seems reasonable, but it looks like it needs some work to enable this only
for the CLI SAPI not the Apache SAPI.  (since these are currently build with the
same configure invocation)
Comment 2 Johannes Schlüter 2006-11-15 08:44:25 EST
Hi Joe,

thanks for the feedback. I think using ext/readline is only linked to the CLI
binary even when other SAPIs are enabled, too. I didn't check it but I think
there's such a flag either in ext/readline/config.m4 or sapi/cli/config.m4.

Greetings from Germany,
johannes
Comment 3 Joe Orton 2006-11-27 11:35:09 EST
php-5.1.6-3.2.fc6 has been pushed to FC6 updates-testing, which should contain
the fix for this bug.  You can test the new packages by running:

  # yum --enablerepo=updates-testing update php


Note You need to log in before you can comment on or make changes to this bug.