Bug 210601 - Clock applet timezone wrong
Clock applet timezone wrong
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 00:00 EDT by Kasper Dupont
Modified: 2008-01-02 10:57 EST (History)
0 users

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 10:57:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2006-10-13 00:00:46 EDT
Description of problem:
The clock applet (/usr/lib/kde3/clock_panelapplet.so) does not show the correct
time zone if the user's time zone differs from the system.

Version-Release number of selected component (if applicable):
kdebase-3.5.4-0.5.fc5

How reproducible:
Happens always

Steps to Reproduce:
1. Configure system for one time zone
2. As an unpriveleged user set your TZ environment variable to a different time
zone. (Must be in a place that gets read before the panel is started, .bashrc
works for me)
3. Log out and in.
  
Actual results:
The clock applet still shows the default time zone for the system

Expected results:
The clock applet shows the time zone chosen by the user.

Additional info:
Through /proc I have verified that kicker does in fact have the TZ environment
variable. I have also verified that using xclock, typing date on the command
line, or using the ctime library function all use the timezone given in the TZ
environment variable.
Comment 1 Lukáš Tinkl 2008-01-02 10:48:02 EST
Still a problem in F8
Comment 2 Lukáš Tinkl 2008-01-02 10:57:14 EST
Actually, trying again after logout/login again, it works correctly. (kdebase 
3.5.8 on F7/F8), the TZ variable has to be set prior starting kicker (ie. the 
whole KDE session)

Note You need to log in before you can comment on or make changes to this bug.