Bug 210604 - reposync -r repoid downloads to ./repoid instead of .
reposync -r repoid downloads to ./repoid instead of .
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 01:28 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 22:44:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-10-13 01:28:27 EDT
Description of problem:

reposync --help says it will download to "current dir".

"reposync -n -r updates" however downloads to "./$(repoid)"

I.e. documentation doesn't match behavior.

Version-Release number of selected component (if applicable):
yum-utils-0.6-3.fc5

How reproducible:
Always.

Steps to Reproduce:
1.reposync -n -r updates
  
Actual results:
Downloading to ./updates

Expected results:
Downloading to .

Additional info:
I can't find downloading to ./repoid to be useful, because this imposes
(invalid) assumptions on a user's filesystem layout.
Comment 1 Seth Vidal 2006-10-16 22:44:41 EDT
it's being downloaded to a subdir named repoid b/c it is possible to run:
reposync -r foo -r bar

if we just downloaded to cwd w/o a subdir then all the packages would be in one
dir and you wouldn't be able to know which came from foo and which from bar.

This isn't a bug, it's an intentional design choice.

sorry.
Comment 2 Ralf Corsepius 2006-10-16 23:04:42 EDT
(In reply to comment #1)
> This isn't a bug, it's an intentional design choice.
Well, ... a very questionable design, or at least a fairly under-documented
tool, IMO.

More generally speaking, then reposync is not the tool I was looking for:

I am actually looking for is a tool to sync /var/cache/*/packages, and tried to
apply reposync for this. This current design forces me to resort to a tree of
symlinks to /var/cache/*/packages instead of being able to 
cd /var/cache/xxx/packages
reposync -r xxx 
which I had expected to work.

Even better would be a tool similar to reposync which directly downloads to
/var/cache/*/packages, instead.

Note You need to log in before you can comment on or make changes to this bug.