Bug 210611 - xmllint fails in system-config-cluster
Summary: xmllint fails in system-config-cluster
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-13 10:15 UTC by Jos Vos
Modified: 2012-11-07 20:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 18:52:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cluster.conf file causing Relax-NG validation errors (1.22 KB, text/plain)
2006-10-13 13:32 UTC, Jos Vos
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 867022 None None None Never

Description Jos Vos 2006-10-13 10:15:57 UTC
Description of problem:
Since version 1.0.27-1.0, system-config-cluster runs xmllint to validate the
cluster.conf against a Relax-NG scheme.  This always fails, for both existing
configurations and for newly created configurations with this version.

Version-Release number of selected component (if applicable):
1.0.27-1.0

How reproducible:
Create a configuration, save it, and restart system-config-cluster.

Solution:
Fix the Relax-NG scheme or put back the "return" as first statement in the
check_xml() function in CommandHandler.py, as it existed in previous versions.

Comment 1 Jim Parsons 2006-10-13 12:47:36 UTC
Keeping the relax ng file current with additions to the cluster schema is a
challenging job. In addition, the xmllint relaxng checker has its own
challenging issues :) Could you please attach a copy of the cluster.conf that is
failing? Please XXX out your passwords, but leave the structure intact and I
will be able to improve the relaxng file from your example.

BTW, the return statement you refer to above was a debug statement that was
inadvertently left in one release cycle when the conf schema went through alot
of changes. 

Comment 2 Jos Vos 2006-10-13 13:32:02 UTC
Created attachment 138430 [details]
cluster.conf file causing Relax-NG validation errors

With this cluster.conf file, created from scratch and mostly with dummy values,
I get the following errors:

/etc/cluster/cluster.conf:20: element cman: Relax-NG validity error : Expecting
element gulm, got cman
Relax-NG validity error : Extra element fencedevices in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element
cluster failed to validate content
/etc/cluster/cluster.conf fails to validate

The error showed up after adding the fence devices (I did a save/restart after
configuring every major element).

I get exactly the same errors with my more complex cluster.conf file,
containing a more useful configuration :-).

Comment 3 Jim Parsons 2006-10-23 17:06:31 UTC
Fixed in s-c-cluster rhel4 head. Missed an ipmilan attr.

Comment 5 Lon Hohberger 2010-01-22 18:52:27 UTC
I verified this fixed in system-config-cluster-1.0.54-2.0; I have not checked prior releases.


Note You need to log in before you can comment on or make changes to this bug.