Bug 210658 - GTK+ media icons not superseded by icon themes
GTK+ media icons not superseded by icon themes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: icon-naming-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 12:07 EDT by Bastien Nocera
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-14 19:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-10-13 12:07:59 EDT
Load an named icon called "gtk-media-pause", and it won't be themed because the
themes use "media-pause", or "stock-media-pause" instead.

The same applies to the other GTK_STOCK_MEDIA_* icons in gtk+.
Comment 1 Matthias Clasen 2006-10-14 19:12:14 EDT
It is the themes responsibility to cover both gtk stock and icon-naming spec
names. One could consider making icon-naming-utils create symlinks for the stock
gtk media icons, but that is somewhat questionable, since gtk has rtl versions
too, and we don't want to theme just the ltr versions. It is probably better to
have ion themes explicitly cover stock icons. I have recently posted a script to
gnome-themes-list@gnome.org which can help ensuring good coverage, and I have 
used it to improve the Bluecurve coverage.

Please take this upstream.

Note You need to log in before you can comment on or make changes to this bug.