Bug 2107 - When Installing from local hard disk, RedHat directory must be root
When Installing from local hard disk, RedHat directory must be root
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-10 01:52 EDT by Theodore Tso
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-15 11:39:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Theodore Tso 1999-04-10 01:52:05 EDT
When installing RedHat from a local hard drive, if the
RedHat directory isn't in the root, the install program
will complain that it can't find the RedHat files.
This is because the check for
/tmp/rhimage/RedHat/base/stage2.img in earlymethods.c is
hardcoded, and so it doesn't matter what directory you
select in the dialog box.  If the RedHat directory isn't at
the top-lvel of the hard drive, you will lose.

Fix is to make earlymethods.c take into account the
directory name given by the user when testing to see if
Redhat/base/stage2.img and ReDHat/base/hdlist exist.
Comment 1 Cristian Gafton 1999-04-12 13:05:59 EDT
assigned to msw
Comment 2 Matt Wilson 1999-04-13 14:29:59 EDT
/* the physical device is mounted on /tmp/hdimage, but all
	   access are through /tmp/rhimage which points to the RedHat
	   directory in /tmp/hdimage */

	dest = alloca(strlen(dir) + 20);
	sprintf(dest, "/tmp/hdimage/%s", dir);

        if (symlink(dest, "/tmp/rhimage")) {
Comment 3 Matt Wilson 1999-04-15 11:39:59 EDT
Fixed in my devel tree.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.