Bug 210705 - kickstart.py throws exception in wrong BIOS disk condition (weekly build 10/12/06)
kickstart.py throws exception in wrong BIOS disk condition (weekly build 10...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
: Reopened
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-10-13 16:20 EDT by Rezwanul Kabir
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 11.1.2.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 09:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rezwanul Kabir 2006-10-13 16:20:25 EDT
Description of problem:

 anaconda throws exception when it actually COULD find a BIOS disk.

 The method "doPartition" in kickstart.py contains the followings:

  def doPartition(self, id, args):
        KickstartHandlers.doPartition(self, args)
        pd = self.ksdata.partitions[-1]
        uniqueID = None

        if pd.onbiosdisk != "":
            pd.disk = isys.doGetBiosDisk(pd.onbiosdisk)

            if pd.disk != "":
                raise KickstartValueError, formatErrorMsg(self.lineno, 
msg="Specified BIOS disk %s cannot be determined" % pd.disk)

  


Version-Release number of selected component (if applicable):

anaconda-11.1.0.108-1 ( weekly build 10/12/06 )

How reproducible:

Always with BIOS disk option in ks.cfg.

Steps to Reproduce:
1.Use ks.cfg with BIOS disk option
2.
3.
  
Actual results:

 The following error messages are printed:

(F6) Error Parsing Kickstart Config
 	The following error was found while parsing your kickstart
         configuration:
 	The following problem occurred on line 35 of the kickstart file:
	Specified BIOS disk sda cannot be determined
 		(Button)Reboot

Expected results:

 Install should go on without any error

Additional info:
Comment 1 Rezwanul Kabir 2006-10-16 15:51:39 EDT
This bug is blocking Dell's internal test efforts. Can we get the fix at least 
in the next weekly build and preferably a test rpm even before that to verify 
that the issue has been fixed?
Comment 2 Chris Lumens 2006-10-18 15:30:43 EDT
--onbiosdisk takes a number corresponding to a BIOS disk like 80, 82, etc. 
Perhaps pykickstart should be modified to detect this.
Comment 3 Rezwanul Kabir 2006-10-18 15:48:22 EDT
Why is it NOTABUG?
Comment 4 Chris Lumens 2006-10-18 16:09:38 EDT
Because you're giving --onbiosdisk the wrong information (the string "sda"
apparently, instead of an integer), and it is rightly displaying an error
message to tell you so.  I will modify the error checking for --onbiosdisk to
expect an integer instead of a string, however, to make it more clear what the
problem is.
Comment 5 Rezwanul Kabir 2006-10-18 16:22:52 EDT
Not sure where you got the info about the content of the ks.cfg. But below
is what ks.cfg contained...

part /boot --fstype ext3 --size=100 --onbiosdisk=80 --asprimary
part pv.23225 --size=0 --grow --onbiosdisk=80


Note, onbiosdisk has 80.
The issue here is below,

   pd.disk = isys.doGetBiosDisk(pd.onbiosdisk)

            if pd.disk != "":


  pd.disk here should contain string such as "sda" and you are raising 
exception when you have a non NULL string...



   
Comment 6 Chris Lumens 2006-10-18 17:07:33 EDT
I was getting the info about ks.cfg from the error message you pasted into the
bug report, since I didn't see any piece from your kickstart config posted.  I
was trusting the error message to be correct, but now that I see what you're
doing I know that's not the case.  I'll commit this for the next build of
anaconda.  Thanks.
Comment 7 Rezwanul Kabir 2006-10-24 16:22:45 EDT
Is this fix confirmed for beta2?
Comment 8 Chris Lumens 2006-10-24 16:32:27 EDT
Yes, it looks like the fix made it into the beta 2 tree.
Comment 9 Amit Bhutani 2006-11-03 01:29:45 EST
Fix verified. Please close. Thanks!

Note You need to log in before you can comment on or make changes to this bug.