Bug 210720 - translations with charset=CHARSET crash anaconda
Summary: translations with charset=CHARSET crash anaconda
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-13 21:13 UTC by Bill Nottingham
Modified: 2014-03-17 03:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 15:22:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2006-10-13 21:13:36 UTC
Description of problem:

[notting@nostromo: ~/prog/anaconda]$ LANG=fa_IR ./anaconda --test --method
nfs://curly.devel.redhat.com/vol/engineering/devarchive/redhat/nightly/rawhide-latest/development/i386/os/
Traceback (most recent call last):
  File "./anaconda", line 588, in ?
    import signal, traceback, string, isys, iutil, time
  File "isys/isys.py", line 26, in ?
    import iutil
  File "/home/notting/prog/anaconda/iutil.py", line 21, in ?
    from flags import flags
  File "/home/notting/prog/anaconda/flags.py", line 16, in ?
    from constants import *
  File "/home/notting/prog/anaconda/constants.py", line 51, in ?
    from pykickstart.constants import *
  File "/usr/lib/python2.4/site-packages/pykickstart/__init__.py", line 3, in ?
    import parser
  File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", line 29, in ?
    translate.textdomain("pykickstart")
  File "/usr/lib/python2.4/site-packages/rhpl/translate.py", line 220, in textdomain
    cat.setDomain(domain)
  File "/usr/lib/python2.4/site-packages/rhpl/translate.py", line 106, in setDomain
    self.updateCachedCatPaths()
  File "/usr/lib/python2.4/site-packages/rhpl/translate.py", line 140, in
updateCachedCatPaths
    catalog = gettext.GNUTranslations(mofile)
  File "/usr/lib/python2.4/gettext.py", line 177, in __init__
    self._parse(fp)
  File "/usr/lib/python2.4/gettext.py", line 324, in _parse
    tmsg = unicode(tmsg, self._charset)
LookupError: unknown encoding: CHARSET

This is due to the fa pykickstart translation having 'charset=CHARSET' in it.
Various other pykickstart translations are similar.

No, I don't know why this doesn't crash in non-test mode.

Version-Release number of selected component (if applicable):

pykickstart-0.35-1

How reproducible:

Every time.

Comment 1 Bill Nottingham 2006-10-13 21:23:06 UTC
Actually, this crashes in non-test mode if you pick 'Kannada', which has
charset=CHARSET translations for both rhpl and pykickstart.

Comment 2 Bill Nottingham 2006-10-13 22:11:26 UTC
OK, new rhpl, rhpxl, pykickstart, system-config-date, and system-config-keyboard
built. Wheeee!

Comment 3 Chris Lumens 2006-10-16 15:22:51 UTC
How aggravating.  I assume these have been moved into the FC6 tree?

Comment 4 Bill Nottingham 2006-10-16 15:34:03 UTC
Yep.


Note You need to log in before you can comment on or make changes to this bug.