Bug 210744 - Kernel Panic caused by IO-APIC + timer
Kernel Panic caused by IO-APIC + timer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 03:14 EDT by Jeremiah Savage
Modified: 2007-12-30 21:28 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.18-1.2849.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-30 21:28:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremiah Savage 2006-10-14 03:14:56 EDT
Description of problem:
On my Macbook I get APIC related Kernel Panics on most (~4/5) boots - complete
message below. Boot with 'apic=debug' does not give any extra information.

Version-Release number of selected component (if applicable):
Currently running 2.6.18-1.2768.fc6, but problems really began about 4 kernels
ago (I believe 2641). Before that, I had the same panics about 1/15 boots.

# uname -a
Linux fedbook 2.6.18-1.2768.fc6 #1 SMP Wed Oct 11 18:23:51 EDT 2006 i686 i686
i386 GNU/Linux

How reproducible:
Most boots (aprox. 4 of 5)

Steps to Reproduce:
boot without 'noapic'
attempted 'apic=debug' but results are the same and no extra information is given.

Actual results:
Screen shows the following (copied by hand, so hopefully no errors):

ACPI: Core revision 20060707
CPU0: Intel Genuine Intel(R) CPU        1400 @ 1.83GHZ stepping 08
SMP Alternatives: switching to SMP code
Booting processor 1/1 eip 3000
CPU 1 irqstacks, hard=c07af000 soft=c078f000
Initializing cpu#1
Calibrating delay using timer specific routine.. 3661.89 BogoMIPS (lpj=7323789)
monitor/mwait feature present
CPU: L1 I code: 32K, L1 D cache: 32K
CPU: L2 cache: 2048K
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
Intel machine check architecture supported
Intel machine check reporting enabled on CPU#1
CPU1: Intel Geniuine Intel(R) CPU        1400 @ 1.83GHz stepping 08
Total of 2 processors activated (3915.84 BogoMIPS)
ENABLING
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
..MP-BIOS bug: 8254 timer not connected to IO-APIC
...trying to set up timer (IRQ0) through the 8259A ...  failed.
...trying to set up timer as Virtual Wire IRQ... failed.
...trying to set up timer as ExtINT IRQ... failed.
Kernel panic - not syncing: IO-APIC + timer doesn't work!  Boot with apic=debug
and send a report.  Then try booting with the 'noapic' option
Comment 1 martin bures 2006-10-27 10:27:09 EDT
Using the released version of Fedora Core 6, I get the same problem.  I am
running a 2Ghz Macbook.  I demoed FC6, T2 and did not encounter this problem.
Comment 2 Jeremiah Savage 2006-11-16 01:47:46 EST
Since I've install the latest kernel update 2.6.18-1.2849.fc6 the problem seems
to have been fixed - in 5 reboots, I've had no kernel panics on the Macbook.

Should this bug be closed now?
Comment 3 Jon Stanley 2007-12-30 21:28:40 EST
Closing per comment #11.  Feel free to reopen this bug if the problem recurs.

Note You need to log in before you can comment on or make changes to this bug.