Bug 210769 - yumex crashes with unhandled exception
yumex crashes with unhandled exception
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 12:30 EDT by Thomas Mashos
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 01:36:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Mashos 2006-10-14 12:30:49 EDT
Description of problem:  Yumex crashes everytime I run it.  If I unselect "Load
Yum Metadata" from the "Yum Extender Launcher" I can get into the program, but
if I try to refresh the repos from there it will crash again with the same error


Version-Release number of selected component (if applicable):1.1.4


How reproducible:Happens everytime


Steps to Reproduce:
1.Select Applications, System Tools, Yumex
2.Enter root password
3.Select Ok
  
Actual results:
Yumex crashes during "Building Package Lists: Available"

Expected results:
Yumex should continue to build all package lists and show me programs that need
updated.


Additional info:
The following is the crash dump Yumex gave me

Component: yumex
Version: 1.1.4
Summary: TB4f1d2ecf packages.py:330:<lambda>:AttributeError:
YumAvailablePackageSqlite instance has no attribute 'returnEVR'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1120, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 537, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 1008, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 533, in
build_package_lists
    avail = self.pkgSack.returnNewestByNameArch()
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 287, in
returnNewestByNameArch
   
bestofeach.addList(self._computeAggregateListResult("returnNewestByNameArch",
naTup))
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 323, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 465, in
returnNewestByNameArch
    return yumRepo.YumPackageSack.returnNewestByNameArch(self, naTup)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 563, in
returnNewestByNameArch
    if pkg.EVR > pkg2.EVR:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 330, in <lambda>
    EVR = property(fget=lambda self: self.returnEVR())
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'

Local variables in innermost frame:
self: kmod-sysprof-PAE - 1.0.3-3.2.6.18_1.2726.fc6.i686
Comment 1 Thomas Mashos 2006-10-14 12:33:22 EDT
I forgot to add that I have reproduced this on both my Dell Inspiron 5100
running Fedora Core 6 Test 3 as well as my Homebuilt Athlon XP desktop running
Fedora Core 6 Test 3.  Both systems have had all updates installed and just
recently did yumex fail to work properly
Comment 2 Tim Lauridsen 2006-10-15 01:36:34 EDT
It is an issue with yum-3.0-05, it should be fixed in yum-3.0-06 currently in
rawhide.

Note You need to log in before you can comment on or make changes to this bug.