Bug 210771 - yum-updatesd fails silently at startup
yum-updatesd fails silently at startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-14 13:22 EDT by Need Real Name
Modified: 2014-01-21 17:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 15:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of -x output (311.27 KB, image/png)
2006-10-16 15:28 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2006-10-14 13:22:03 EDT
yum-updatesd is the only service to fail to stop on shutdown.

Will post logs if this is uncommon.
Comment 1 Jeremy Katz 2006-10-15 20:14:27 EDT
It stops fine for me... how does it fail?
Comment 2 Need Real Name 2006-10-16 02:33:20 EDT
I don't know. I get no error, and the logs have nothing useful in them.

Apart from adding -x to the init script, how can I get it to show me what's wrong?
Stopping it manually right now works find, it only fails on shutdown.
Comment 3 Jeremy Katz 2006-10-16 10:40:50 EDT
-x is probably the best bet... it shuts down fine for me in a Xen guest where I
just tried.  Does it _always_ fail on shutdown for you?
Comment 4 Need Real Name 2006-10-16 12:38:54 EDT
Running from runlevel 1, with ifup eth01, the problem seems to be not stopping,
but starting.

If I run yum-updatesd manually, it silently fails.
Running it through strace shows it cannot find dbus_bindings.pyx (or similar)
Comment 5 Jeremy Katz 2006-10-16 12:49:28 EDT
Do you have dbus-python installed?  Can you run
  /usr/sbin/yum-updatesd --no-fork
and see how it errors?
Comment 6 Need Real Name 2006-10-16 15:08:31 EDT
# rpm -q dbus-python
dbus-python-0.70-6

At runlevel 1:
# /usr/sbin/yum-updatesd --no-fork
Traceback (most recent call last):
  File "/usr/sbin/yum-updatesd", line 29, in ?
    yumupd.main()
  File "/usr/share/yum-cli/yumupd.py", line 595, in main
    updd = UpdatesDaemon(opts)
  File "/usr/share/yum-cli/yumupd.py", line 304, in __init__
    self.emitters.append(DbusUpdateEmitter())
  File "/usr/share/yum-cli/yumupd.py", line 174, in __init__
    bus = dbus.SystemBus()
  File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 260, in __new__
    return Bus.__new__(cls, Bus.TYPE_SYSTEM, use_default_mainloop, private)
  File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 99, in __new__
    bus._connection = dbus_bindings.bus_get(bus_type, private)
  File "dbus_bindings.pyx", line 1692, in dbus_bindings.bus_get
dbus_bindings.DBusException: Failed to connect to socket
/var/run/dbus/system_bus_socket: Connection refused
Comment 7 Jeremy Katz 2006-10-16 15:09:43 EDT
Oh, duh.  In runlevel 1, dbus isn't running.  You'll need to start the
messagebus service first
Comment 8 Need Real Name 2006-10-16 15:11:18 EDT
Okay, so why does it fail on shutdown?
Comment 9 Need Real Name 2006-10-16 15:11:54 EDT
It's running now. Let me reboot, and see if it fails to shutdown.
Comment 10 Need Real Name 2006-10-16 15:28:03 EDT
Created attachment 138613 [details]
Screenshot of -x output

Looks like it can't get the pid.
/var/run/yum-updatesd.pid does not exist on my box, but /usr/bin/python
/usr/sbin/yum-updatesd
 is running.
Comment 11 Julian Sikorski 2006-10-28 18:00:14 EDT
This happens for me as well
Comment 12 Jeremy Katz 2006-11-06 15:26:03 EST
Yeah, but pidof should be finding it fine... does 'pidof -x yum-updatesd' find
the pid while the system is running?
Comment 13 Need Real Name 2006-11-06 15:29:47 EST
[root@box ~]# pidof -x yum-updatesd
2333

[root@box ~]# ps axww|grep yum
 2333 ?        S      0:11 /usr/bin/python /usr/sbin/yum-updatesd
 4771 pts/0    S+     0:00 grep yum
Comment 14 Julian Sikorski 2006-11-06 15:31:12 EST
Seconded:
[root@fcdesktop ~]# pidof -x yum-updatesd
2483
Comment 15 Need Real Name 2006-11-06 15:33:01 EST
[root@box ~]# ls /var/run/y*
ls: /var/run/y*: No such file or directory
Comment 16 Julian Sikorski 2006-11-06 16:47:56 EST
To make it clear: running
/etc/rc.d/init.d/yum-updatesd stop
from the command line works flawlessly.
Comment 17 Bill Marrs 2007-01-09 09:50:28 EST
I suggest that the title for this bug be changed from "yum-updatesd fails to 
stop on shutdown" to "yum-updatesd fails silently at startup".

This affected me.  I had a small bug in the config file (/etc/yum/yum-
updatesd.conf).  I'd forgotten an ='s on a line I added.  But, this didn't 
prevent "service yum-updatesd start" from saying " [  OK  ]".  So, I assumed it 
was working.  But, in fact, it failed at startup.  

Doing a "service yum-updatesd stop" will report "[FAILED]", because it wasn't 
running.  But, this isn't very helpful.

I couldn't fund any logfile that contained a message saying there was a 
problem.  Finally, I tracked down this bug and saw the suggestion to 
try "/usr/sbin/yum-updatesd --no-fork".  This reported the problem with my 
config file.  I was able to fix it and it's all working for me now.

But, I think it's clear that yum-updatesd has to do a better job of reporting 
what went wrong when it fails to startup.  

o "service yum-updatesd start" should not report "[  OK  ]"
o The error should be printed and logged somewhere (/var/log/messages ?)
Comment 18 Need Real Name 2007-04-02 14:27:16 EDT
Changing to devel so that someone notices!
Comment 19 Seth Vidal 2007-08-03 15:29:57 EDT
Could either of you test yumupdatesd in rawhide and let me know if that solves
the problems in this bug? Reopen the bug if it does not.
Comment 20 Need Real Name 2007-08-05 12:21:20 EDT
To increase the chance of other people trying this, here is the copy and paste
version:
 yum --enablerepo=development upgrade yum-updatesd

I've installed it and will test with the next yum update.

Note You need to log in before you can comment on or make changes to this bug.