This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 210799 - anaconda crashed on 2 partitioning operations
anaconda crashed on 2 partitioning operations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 05:56 EDT by Andreas Klemm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 09:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crashdump when trying to create a partition in ~176MB free space of hda (51.21 KB, text/plain)
2006-10-15 06:25 EDT, Andreas Klemm
no flags Details
Another crashdump, maybe to compare with the other one ... (49.05 KB, text/plain)
2006-10-15 06:28 EDT, Andreas Klemm
no flags Details

  None (edit)
Description Andreas Klemm 2006-10-15 05:56:59 EDT
Description of problem:
This problem is with the pre-release DVD (past fc6-test3), but this
particular version was not selectable in bugzilla).
Problem 1: anaconda crashes when removing a volume group.
Problem 2: anaconda crashes when creating a new partition

Version-Release number of selected component (if applicable):


How reproducible:

Don't know if this is important to reproduce:
My 1st 180GB IDE disk already contains an XP installation
with several primary and extended partitions which I intended
to wipe out. My Pentium III's BIOS is old and only recognizes
8GB out of 180GB. But XP and FreeBSD don't have any problems
with it in the past.
I wanted to wipe out everything on that disk to make a test
installation of Fedora on this disk.

Failure 1 occured when selecting to wipe the disk with standard
Layout.

Steps to Reproduce:
1. anaconda creates 2 partition in a VolGroup 00
2. I re-designed the partitions in the VolGroup 00 to have separate
   root(1G), swap(1984M), tmp(512M), var(2G), opt(2G), usr(8G),
   home (4G) filesystems.
3. Decided to delete and recreate the volgroup 00, since I wanted to
   leave a rest for other OS on this disk and simply to see, if I
   can trimmed down the size of VolGroup 00 from 176GB to 20GB, which
   filts my demand more.
   As soon as I selceted the VolGroup 00 and hit delete, anaconda crashed.

After reboot I wanted to make a customized layout directly, to workaround
this bug.

1. First I deleted all my partitions of my 1st disk.
   3 primary partitions (hda1 - hda3) then the logical volumes
   of my extended Partition (3). Finally hda4, the extended partition
   itself. Finally there was only Freespace on this disk hda.
2. anaconda crashed immediately after hitting the "new" button
   when I wanted to create the 1st partition of my new partitioning
   scheme which I had in mind after cleaning up on hda.

Actual results:

Not able to fine tune the partitioning layout to my needs, because
every finetuning attempt I did up to now seems to crashes anaconda.
Will try now to wipe the disk with 3rd party tools,
before installing fc-6 pre-version.
And then directly use customized partitioning layout.

Expected results:

Be able to finetune partitions with the operations that anaconda
offers without a crash until the partitioning satisfies my needs.
I must be able to finetune the partitioning suggestions that
anaconda makes. If selections are user customizeable, then all
options you offer to user have to be stable.

Additional info:
Comment 1 Andreas Klemm 2006-10-15 06:25:23 EDT
Created attachment 138523 [details]
Anaconda Crashdump when trying to create a partition in ~176MB free space of hda

This trace is concerning the 2nd reported anaconda crash in my bugreport.
So this bug is reproduceable ;-)
Steps:

X11 based (normal) installation, no other options on the 1st prompt

1. selected only hda (176699 MB), hdb deselected
2. choosed "create custom layout"
3. selected hda4 (Extended partition, containing hda5, hda6, hda7, all ntfs)
   and hit delete button
4. Deleted all remaining partitions (hda3, hda2, hda1) by selecting and
   hitting delete button.

Now all partitions are cleared on hda and I have 
176700MB freespace from cyl 1 - 22527

5. I select now this freespace (select with click on left mousebutton,
   so that its highlighted with blue background)
6. click on "new", to create a new partition, then anaconda crashes.

Did that a 3rd time now .. easily reproduceable.
Comment 2 Andreas Klemm 2006-10-15 06:28:44 EDT
Created attachment 138524 [details]
Another crashdump, maybe to compare with the other one ...

Here another crashdump I got.
Maybe you compare with the 1st one.
Its the same operation that I did before to get 1st crashdump.
Maybe its important for you to compare them.
At least you see clearly now that its reproduceable.
Comment 3 Chris Lumens 2006-10-15 09:59:17 EDT
This is fixed for FC6 final.

Note You need to log in before you can comment on or make changes to this bug.