Bug 210807 - Flash plugin causes galeon crash/exit
Flash plugin causes galeon crash/exit
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 09:11 EDT by Denis Leroy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 10:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2006-10-15 09:11:42 EDT
Any flash plugin will cause an immediate galeon exit from an X11 error :

> galeon --sync --disable-crash-dialog http://www.youtube.com/
The program 'galeon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 120 error_code 8 request_code 146 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.) 


I talked to Philip Langdale, but he had no immediate suggestions. Since the
flash plugin works fine with both Firefox and Epiphany, I suspect something is
wrong either with the way galeon is build (against firefox-devel), or possibly
some environment problem makes the plugin unhappy...
Comment 1 Denis Leroy 2006-10-19 10:08:56 EDT
Some more information here:

https://launchpad.net/distros/ubuntu/+source/firefox/+bug/23392

Added g_setenv to galeon source code to fix this issue.

Note You need to log in before you can comment on or make changes to this bug.