Bug 210833 - apt has incorrect arch directory for ppc
apt has incorrect arch directory for ppc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 20:14 EDT by Adam Goode
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5.15lorg3.2-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 21:07:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for archtable for ppc (458 bytes, patch)
2006-10-15 20:16 EDT, Adam Goode
no flags Details | Diff

  None (edit)
Description Adam Goode 2006-10-15 20:14:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
apt uses "powerpc" for fetching files from Fedora servers. But this should really be "ppc". I am attaching a patch which fixes this.

Version-Release number of selected component (if applicable):
apt-0.5.15lorg3.2-7.fc5

How reproducible:
Always


Steps to Reproduce:
1. apt-get update

Actual Results:


Expected Results:


Additional info:
Comment 1 Adam Goode 2006-10-15 20:16:52 EDT
Created attachment 138541 [details]
patch for archtable for ppc
Comment 2 Axel Thimm 2006-10-16 06:09:23 EDT
Thanks, the patch looks OK from a Fedora POV. I've added Panu, the apt
maintainer, to the Cc. Panu, what do you think? Is the patch acceptable, should
I add it to the package?

As a workaround (for people reading this before it gets fixed) you can replace
the arch variables and hardwire "ppc" in the sources.list.
Comment 3 Panu Matilainen 2006-10-16 16:32:49 EDT
The archtable is a mess - stuff collected over time from Debian, Suse and who
knows what distros. If it fixes things for Fedora, go ahead and add to the FE
package.

For upstream purposes, I need to do some studying on what various distros expect
it to be (wrt ppc especially since that's an unknown beast to me) and whether it
could sanely be moved to being runtime detectable (or at least configurable) thingy.
Comment 4 Adam Goode 2006-11-08 08:37:00 EST
Any word on this? Looks like the patch should just go in.
Comment 5 Axel Thimm 2006-11-23 12:21:56 EST
Does the latest package, 0.5.15lorg3.2-8, (still in the needsign queue, but
should be available in the next hours) fix this?
Comment 6 Adam Goode 2006-11-24 18:55:17 EST
Yes! Works perfectly on FC6. Thanks.

Note You need to log in before you can comment on or make changes to this bug.