Bug 2108546 - missing requirement on newer criu (undefined symbol: criu_join_ns_add)
Summary: missing requirement on newer criu (undefined symbol: criu_join_ns_add)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: crun
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Giuseppe Scrivano
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-19 09:53 UTC by Lukáš Zachar
Modified: 2022-07-30 01:26 UTC (History)
5 users (show)

Fixed In Version: crun-1.5-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-30 01:26:04 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Lukáš Zachar 2022-07-19 09:53:47 UTC
Description of problem:

When running `podman run` it fails with crun missing symbol.

Version-Release number of selected component (if applicable):
crun-1.4.5-1.fc35

How reproducible:
always

Steps to Reproduce:
1. Boot VM (e.g. Fedora-Cloud-Base-35-1.2.x86_64.qcow2)
2. dnf install -y podman
3. podman run fedora

Actual results:
2. podman and crun are installed from 'updates' but criu is installed from 'fedora'

3. /usr/bin/crun: symbol lookup error: /usr/bin/crun: undefined symbol: criu_join_ns_add
ERRO[0011] Error removing container 7f4fb71cc000a02a25c2fa1acb93e45d0ab8cef94dfcde25251979909f113f5b from runtime after creation failed 
Error: OCI runtime error: /usr/bin/crun: symbol lookup error: /usr/bin/crun: undefined symbol: criu_join_ns_add


Expected results:
since crun needs newer criu it will require it so dnf installs it properly

Additional info:
Fix by `dnf update criu`

Comment 1 Fedora Update System 2022-07-21 13:51:30 UTC
FEDORA-2022-a8c532437f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a8c532437f

Comment 2 Lokesh Mandvekar 2022-07-21 13:57:44 UTC
f36 update is at https://bodhi.fedoraproject.org/updates/FEDORA-2022-8593b9ea9c . I added the wrong bz id so it didn't show up here. My bad.

Comment 3 Fedora Update System 2022-07-22 05:17:10 UTC
FEDORA-2022-a8c532437f has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a8c532437f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a8c532437f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2022-07-30 01:26:04 UTC
FEDORA-2022-a8c532437f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.