Bug 210865 - xpdf -fullscreen keeps Gnome panels
xpdf -fullscreen keeps Gnome panels
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-10-16 08:25 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.02-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-01 23:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2006-10-16 08:25:51 EDT
Description of problem:
xpdf in fullscreen (presentation) mode doesn't use the whole screen, the Gnome
panels still show up.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.xpdf -fullscreen FILE.pdf
Actual results:
Gnome top and bottom panels around the presentation

Expected results:
xpdf using the full screen

Additional info:
Comment 1 Tom "spot" Callaway 2006-10-18 01:17:46 EDT
Got any idea how to make a Motif application go to full screen properly? :)

I tried adding:
XtVaSetValues (shell, XmNoverrideRedirect, TRUE, NULL);

But while that does make it fullscreen, it also loses keyboard (or rather,
keyboard goes to the shell, not to the application). I'm not a motif expert in
the slightest, not sure how to fix this.
Comment 2 Horst H. von Brand 2007-07-17 09:55:31 EDT
Still the same with xpdf-3.01-28.fc7
Comment 3 Fedora Update System 2007-08-01 23:42:43 EDT
xpdf-3.02-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.