Bug 210868 - Error in udev rule
Summary: Error in udev rule
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openct (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-16 12:52 UTC by Torsten Rausche
Modified: 2009-06-27 15:42 UTC (History)
2 users (show)

Fixed In Version: 0.6.9-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 18:26:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Torsten Rausche 2006-10-16 12:52:33 UTC
Description of problem:
Udev is moaning while loading openct's rule. The line mentioned in the output is
related to PCMCIA. I do not have PCMCIA hardware and therefore I have no
corresponding packages installed.

udevd: add_to_rules: invalid BUS operation
udevd: add_to_rules: invalid rule '/etc/udev/rules.d/60-openct.rules:49'


Version-Release number of selected component (if applicable):
openct 0.6.9-2.fc6
udev   095-14


How reproducible:
Always.


Steps to Reproduce:
1. Setup a system without PCMCIA.
2. Look at the screen ouput while booting.

  
Actual results:
Udev shows error messages related to openct.


Expected results:
No error messages.

Comment 1 Ville Skyttä 2006-10-16 17:35:44 UTC
Hm, I have a similar system (without PCMCIA), but it's a FC5 with udev 084 and 
that udev doesn't seem to mind it.  I have no FC6testX system available at the 
moment to test with.

Anyway, looks like the culprit line 49 in /etc/udev/rules.d/60-openct.rules 
may have a simple bug: does changing 'BUS=' to 'BUS==' in it help?

Comment 2 Torsten Rausche 2006-10-16 18:03:19 UTC
Yes, this seems to fix it.

Comment 3 Ville Skyttä 2006-10-16 18:26:16 UTC
Fixed in 0.6.9-3.fc6 which will hit the repository soonish.


Note You need to log in before you can comment on or make changes to this bug.