Bug 21087 - Anaconda Installer Locks up
Anaconda Installer Locks up
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-19 12:26 EST by Josen
Modified: 2007-03-26 23:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 13:19:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josen 2000-11-19 12:26:51 EST
I am attempting to install RH 7 on an older HP Vectra Pentium 75 machine 
that does not have any USB controllers, USB devices, etc. 

While anaconda is loading it confirms whether there is a USB controller or 
not. In my case it acknowledges that there is no USB controller and 
continues on until it starts a search for a USB mouse. At this point it 
does not find a USB mouse and it locks up.......never to move forward or 
give me an error message or anything.

Alt+F2 reports: sh-2.04# _

Alt+F3 reports: * looking for USB mouse...

Alt+F4 reports: <6>raid5 personality registered

Is there any work around to this? 

I would suspect that this problem is being encountered by many others as 
RH is being toyed with on lots of older machines. 

Your help is appreciated.

Thanks, Josen
Comment 1 Michael Fulbright 2000-11-20 15:08:13 EST
Please try booting into the installer with the 'nousb' option, like


'linux nousb'

and tell us if that helps.
Comment 2 Josen 2000-11-20 22:48:04 EST
I tried your suggestion and still am experiencing a lock up. The halt is 
happening in the same spot. However Alt+F3 no longer reports "* looking for USB 
mouse", instead it hangs one line ahead "* going to insmod ext3.o (path is 
NULL)". All other F+ Keys report what is stated in the original message.
Comment 3 Brock Organ 2000-12-18 11:38:00 EST
hmmm ... I am not seeing this problem in a similar system (P166, no usb devices)
... how much memory does your machine have ...? were you trying to start the
install in text mode or GUI mode ...? The place where you are reporting the hang
is where the installer loads into 'stage 2' and presents the "welcome to red
hat" screen ... I would be interested to know if this behavior occurs for you:

* in text mode 
* explicitly specifying how much memory the machine has
Comment 4 Josen 2000-12-18 11:47:16 EST
Thank you for your continued support. 

The issue has been resolved. I was installing in text mode, which seemed to not 
be the issue. The culprit was incompatible memory simms. I was trying to run 54 
megs of memory in pairs from 3 different manufacturers (6 total simms).

To get beyond my troubles I reduced the memory to 4 identical simms of 4 megs 
each. At that stage everything worked fine. After installation I loaded 
additional memory only to find that the machine wouldn't accept it. 

You can chalk it up to memory hardware incompatibility.

Again, thanks for your help.
Comment 5 Brock Organ 2000-12-18 13:19:36 EST
glad to know you were able to resolve the issue ... thanks for your report! :)

Note You need to log in before you can comment on or make changes to this bug.