Bug 210884 - Header Line 'Copyright not accepted by rpmbuild (v4.4.2) anymore
Header Line 'Copyright not accepted by rpmbuild (v4.4.2) anymore
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: rpm-guide (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glen Rundblom
Karsten Wade
http://fedora.redhat.com/docs/drafts/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 10:22 EDT by Lutz Behnke
Modified: 2015-11-05 22:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 22:18:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lutz Behnke 2006-10-16 10:22:56 EDT
The 'Copyright' Statement for the spec header seems to have been depricated for
a long time. My rpmbuild (v4.4.2) does not even accept it anymore. Use 'License'
instead.


This draft was the only halfway current and at least partially complete
documentation on RPM I could find at all, so it takes on a certain
responsibility to be correct.
Comment 1 Karsten Wade 2006-10-16 10:53:50 EDT
Sorry for the confusion.  The reason this document is in the docs/drafts/
directory structure is *because* it is outdated and needs updating. 
Unfortunately, no one has responded to requests to help update this guide.

Currently, the best information on RPM packaging is found through the Fedora
Extras pages on the subject:

http://fedoraproject.org/wiki/Packaging/Guidelines

If you learn anything more that is incorrect in the rpm-guide, feel free to
continue to file bugs; if you get enough that you want to contribute to it, let
us know. :)

Holding this bug open in anticipation of eventual work progressing on this document.
Comment 2 Karsten Wade 2008-06-04 10:30:58 EDT
Moving to the new rpm-guide component to help in finding and resolving all RPM
Guide bugs.
Comment 3 eric@christensenplace.us 2009-07-09 22:21:32 EDT
This guide is being resurrected.  Reassigned all tickets to developer.
Comment 4 Glen Rundblom 2015-11-05 22:18:36 EST
This bug is 5 years old and probably no longer relevant, closing.

Note You need to log in before you can comment on or make changes to this bug.