Bug 210892 - gnome-screensaver hangs with dual-head setup
gnome-screensaver hangs with dual-head setup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-10-16 10:37 EDT by Jeff Needle
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.16.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 18:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (3.71 KB, application/octet-stream)
2006-10-16 10:37 EDT, Jeff Needle
no flags Details
Output of gnome-screensaver --no-daemon --debug (4.56 KB, application/text)
2006-10-16 11:18 EDT, Jeff Needle
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 358963 None None None Never

  None (edit)
Description Jeff Needle 2006-10-16 10:37:35 EDT
Description of problem:
gnome-screensaver kicks in, blanks the screen, and one of the instances seems to
vanish.  Can't unlock screen except by killing the other instance of
gnome-screensaver.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.0-7.fc6

How reproducible:
100% in my configuration

Steps to Reproduce:
1.My xorg.conf is attached
2.Launch xscreensaver
3.
  
Actual results:
screen 0 blank, no dialogue box to unlock
screen 1 exposed, but panel non-responsive (as if locked)

Expected results:
both screens display screensaver, keystroke presents dialogue box

Additional info:
strace of remaining gnome-screensaver process looks like this (fragment -
continues on)

# strace -p2478
Process 2478 attached - interrupt to quit
restart_syscall(<... resuming interrupted call ...>) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 150000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 150000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000}, NULL)         = 0
stat64("/var/run", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
nanosleep({0, 200000000},  <unfinished ...>
Comment 1 Jeff Needle 2006-10-16 10:37:35 EDT
Created attachment 138579 [details]
xorg.conf
Comment 2 jmccann 2006-10-16 10:43:08 EDT
Looks like you are using Clone mode so it is probably this:
http://bugzilla.gnome.org/show_bug.cgi?id=354663
Comment 3 Jeff Needle 2006-10-16 10:51:49 EDT
Gack.  I don't know how Clone got set.  I'm using 2 different screens, :0.0 and
:0.1, so I guess it's ignoring that option.  Same behavior with Clone set to
off.  Also, not nVidia.  It's an ATI Technologies Inc Radeon RV200 LX [Mobility
FireGL 7800 M7].
Comment 4 jmccann 2006-10-16 10:55:31 EDT
Can you try running gnome-screensaver --no-daemon --debug and attach the output?
Comment 5 Jeff Needle 2006-10-16 11:18:07 EDT
Created attachment 138583 [details]
Output of gnome-screensaver --no-daemon --debug
Comment 6 jmccann 2006-10-16 11:24:13 EDT
Ah, then it is this one:
http://bugzilla.gnome.org/show_bug.cgi?id=358963

Which should be fixed in 2.16.1.
Comment 7 Jeff Needle 2006-10-16 13:41:15 EDT
Just tested 2.16.1 and indeed this does fix it.  Thanks for the quick response!
Comment 8 Matthias Clasen 2006-12-07 18:21:29 EST
With 2.16.1 in dist-fc6-updates, I think we can close this now.

Note You need to log in before you can comment on or make changes to this bug.