Bug 2109124 - [AWS] failed to create cluster on ap-southeast-3
Summary: [AWS] failed to create cluster on ap-southeast-3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.10
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.10.z
Assignee: Radek Maňák
QA Contact: Huali Liu
URL:
Whiteboard:
Depends On: 2065510
Blocks: 2111004
TreeView+ depends on / blocked
 
Reported: 2022-07-20 13:09 UTC by Radek Maňák
Modified: 2022-08-09 02:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The AWS SDK only knows about regions from the time when it was vendored Consequence: Any new regions are not recognised and cannot be used with the Machine controller Fix: Use DesrcibeRegions to check the specified region for a machine rather than relying on the SDK. Note, this is a new AWS permission and manual mode clusters will need to update their credentials with the new permission. Result: New Machines can be created in regions unknown to the SDK.
Clone Of: 2065510
: 2111004 (view as bug list)
Environment:
Last Closed: 2022-08-09 02:36:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 1046 0 None open [release-4.10] Bug 2109124: Add DescribeRegions permission for aws controller 2022-07-26 08:41:39 UTC
Github openshift machine-api-provider-aws pull 48 0 None open [release-4.10] Bug 2109124: Validate unknown regions using AWS API 2022-07-20 13:13:45 UTC
Red Hat Product Errata RHSA-2022:5875 0 None None None 2022-08-09 02:37:05 UTC

Comment 8 errata-xmlrpc 2022-08-09 02:36:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.10.26 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:5875


Note You need to log in before you can comment on or make changes to this bug.