Bug 210916 - Admin Server doesn't start on RHEL3 - libldap60.so + sasl
Admin Server doesn't start on RHEL3 - libldap60.so + sasl
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
: VerifiedUpstream
Depends On:
Blocks: fds103trackingbug
  Show dependency treegraph
 
Reported: 2006-10-16 11:25 EDT by Rich Megginson
Modified: 2015-12-07 12:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:00:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs for fix (2.43 KB, patch)
2006-10-16 11:25 EDT, Rich Megginson
no flags Details | Diff

  None (edit)
Description Rich Megginson 2006-10-16 11:25:59 EDT
The Admin Server doesn't start on RHEL3 with the new libldap60.so because it
doesn't know how to resolve the SASL dependency.  This is not a problem on RHEL4
and FC because httpd is linked directly with libsasl2.so
Comment 1 Rich Megginson 2006-10-16 11:25:59 EDT
Created attachment 138584 [details]
diffs for fix
Comment 2 Nathan Kinder 2006-10-16 11:47:29 EDT
Looks good.
Comment 3 Rich Megginson 2006-10-16 11:57:45 EDT
Reviewed by: nkinder (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: Adding libldap60.so to the LD_PRELOAD solves the problem. 
Loading libldap60.so early forces the dynamic linker to find and resolve
libsasl2.so.  So I modified start-admin to do the LD_PRELOAD of libldap60.  I
also updated the patch file which is used when upgrading 1.0.2 to 1.0.3.
Platforms tested: RHEL3
Flag Day: no
Doc impact: no 

Checking in start-admin;
/cvs/dirsec/adminserver/admserv/cfgstuff/start-admin,v  <--  start-admin
new revision: 1.7; previous revision: 1.6
done
Checking in adminserver-start-admin.patch;
/cvs/dirsec/adminserver/admserv/cfgstuff/adminserver-start-admin.patch,v  <-- 
adminserver-start-admin.patch
new revision: 1.4; previous revision: 1.3
done

Note You need to log in before you can comment on or make changes to this bug.