Bug 2109329 - On-prem loadbalancer ports conflict with kube node port range
Summary: On-prem loadbalancer ports conflict with kube node port range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.11
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.8.z
Assignee: Ben Nemec
QA Contact: Silvia Serafini
URL:
Whiteboard:
: 2100383 (view as bug list)
Depends On: 2101794
Blocks: 2100382
TreeView+ depends on / blocked
 
Reported: 2022-07-21 01:06 UTC by OpenShift BugZilla Robot
Modified: 2022-10-27 05:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-27 05:44:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-runtimecfg pull 187 0 None open [release-4.8] Bug 2109329: Avoid kubernetes node port range 2022-09-01 16:51:50 UTC
Github openshift machine-config-operator pull 3316 0 None open [release-4.8] Bug 2109329: Avoid kubernetes node port range 2022-09-01 16:58:10 UTC
Red Hat Product Errata RHBA-2022:7034 0 None None None 2022-10-27 05:45:03 UTC

Comment 1 Silvia Serafini 2022-09-02 07:41:47 UTC
*** Bug 2100383 has been marked as a duplicate of this bug. ***

Comment 2 Mahesh N 2022-09-13 05:58:13 UTC
Hello @bnemec you are closed one bug on Jira https://issues.redhat.com/browse/OCPBUGS-928 mentioning it will be fixed here,
The port range I see here is 30000 and 30936 , I am facing issue with 50936 will that also be included here? 
Also do we have any timeline for this fix to release?

Comment 3 Ben Nemec 2022-09-19 19:07:06 UTC
Yes, that's just the port number that was used in earlier 4.8 releases. The patches are all proposed so it's just a question of getting the necessary reviews and ci passes on them.

Comment 14 errata-xmlrpc 2022-10-27 05:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.52 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7034


Note You need to log in before you can comment on or make changes to this bug.