Bug 210945 - yum update gives error: unpacking of archive failed on file /home: cpio: chown
Summary: yum update gives error: unpacking of archive failed on file /home: cpio: chown
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-16 17:25 UTC by Nurdin Premji
Modified: 2015-03-05 01:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 04:08:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nurdin Premji 2006-10-16 17:25:58 UTC
Description of problem:
Doing a yum update gives the error

Running Transaction
  Updating  : filesystem                   ######################### [1/2] 
error: unpacking of archive failed on file /home: cpio: chown

Updated: filesystem.i386 0:2.4.0-1
Complete!

Version-Release number of selected component (if applicable):
filesystem-2.3.7-2.1

How reproducible:
every time

Steps to Reproduce:
1. do a yum update
2.
3.
  
Actual results:

Get error message, doing another update tries to update the filesystem package
again. Even though it says completed

Expected results:
No error, package actually installed instead of saying it is installed.

Additional info:

Comment 1 Phil Knirsch 2006-10-17 09:51:56 UTC
That looks like a corrupted or truncated binary rpm package for filesystem.

Please verify if the size and data of that rpm is correct.

Thanks,

Read ya, Phil

Comment 2 Nurdin Premji 2006-10-17 14:26:42 UTC
How do I do this?

Comment 3 Phil Knirsch 2007-05-24 15:06:46 UTC
Typically a rpm -qpVa foo.rpm works to list any problems.

Does this still happen?

Read ya, Phil

PS: Might have been a broken tree at that day as well.

Comment 4 Tim Niemueller 2008-03-18 13:04:46 UTC
This happens our our machines as well. We have /home mounted via NFS from our
central file server. I can upgrade the package if I unmount /home beforehand.
Afterwards I can mount it again.

This happens at least on F8 and rawhide.

Comment 5 Phil Knirsch 2008-03-27 13:54:29 UTC
Ah, i think i finally know where the problem comes from:

NFS is probably mounted RW but without the no_root_squash option. This will lead
to rpm failing when trying to "install" /home with proper permissions and
user/group, see the cpio: chown error message.

So this is basically a configuration problem where rpm and/or the package
filesystem can't do much about.

Read ya, Phil

Comment 6 Tim Niemueller 2008-03-28 09:17:08 UTC
It's mounted with no_root_squash indeed. A way that the cpio error does not fail
the installation would already be helpful, like giving a warning but not
stopping the installation.

Comment 7 Phil Knirsch 2008-03-28 15:48:42 UTC
Not sure if thats already possible at all with RPM as it generally wants to
install every file properly, including user/group and permissions and gets
rather unhappy if it can't for some reason.

I'm CC'ing Panu Matilainen on this bug now as he's our RPM expert and
maintainer, maybe he has an idea.

Read ya, Phil

Comment 8 Panu Matilainen 2008-03-31 07:35:45 UTC
You can tell rpm about NFS paths with %_netsharedpath macro, something like this
should avoid the issue:
echo "%_netsharedpath /home" >> /etc/rpm/macros

Comment 9 Bug Zapper 2008-05-14 02:25:15 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Jon Stanley 2008-05-15 04:08:02 UTC
Closing NOTABUG - This is expected behavior, and Panu provided a workaround a
few months back.


Note You need to log in before you can comment on or make changes to this bug.