Bug 21099 - Install gives an exceptional error and then freezes during the loopback creation process, even when the update disk is used.
Install gives an exceptional error and then freezes during the loopback creat...
Status: CLOSED DUPLICATE of bug 19577
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-19 19:06 EST by Morphal
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-19 14:10:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morphal 2000-11-19 19:06:35 EST
When I boot my computer with the Redhat 7 CD in, and go through the setup 
process, I get an error during the part where it creates the loopback 
system, and the computer freezes.  I am running a PC with a Pentium II 
Xeon processor and 256 megs of ram, and I am installing Linux to an 
existing FAT32 partition.  I get the following error:

Traceback (innermost last):

  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1469, in 
doInstall
    self.fstab.makeFilesystems
  File "fstab.py", line 645, in makeFilesystems
    (self.progressWindow, _("Loopback"),
  File "isys.py", line 78, in ddfile
    os.write(fd, buf)


I was able to reproduce this error every time i tried to install Linux.  
Then, I went to www.redhat.com and downloaded the anaconda fix disk, ran 
the installer again using 'linux updates' and it came up with the screen 
saying to insert the disk, and it read updates from it.  With this disk, I 
get a slightly different error:

Traceback (innermost last):

  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1488, in doInstall
    self.fstab.makeFilesystems
  File "/tmp/updates/fstab.py", line 645, in makeFilesystems
    (self.progressWindow, _("Loopback"),
  File "isys.py", line 78, in ddfile
  OSError: [Errno 27] File too large


I was also able to reproduce this error every time I tried to install 
Linux.
Comment 1 Michael Fulbright 2000-11-20 15:07:23 EST
This is most likely a dupe of bug 19577.

Before we mark it as such, could you give us step by step information on how to
reproduce this problem?
Comment 2 Morphal 2000-11-20 16:03:49 EST
oops...yeah it is a dupe, the same thing happens to me (the freezing up too) 
sorry about that, i didn't see 19577 when I was looking through the list.

also, I did notice that it WOULD install properly when using the text-based 
installer, but not the grahical one.
Comment 3 Michael Fulbright 2000-11-21 10:21:32 EST
No problem - it would really help to have a step by step description of how to
reproduce this issue.  We have not been able to cause this problem to occur in
our test lab so any information is very helpful.
Comment 4 Michael Fulbright 2000-12-19 14:10:26 EST

*** This bug has been marked as a duplicate of 19577 ***

Note You need to log in before you can comment on or make changes to this bug.