Bug 211 - Installation from vfat partition fails (with fix and workaround)
Installation from vfat partition fails (with fix and workaround)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-28 04:48 EST by Marc MERLIN
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-09 17:17:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 1998-11-28 04:48:32 EST
This is possibly a duplicate of bug #32 (it wasn't precise
enough for me to be sure)

I was installing on a laptop were the pcmcia-cs package
on RH 5.2 wasn't recent enough to work with the pcmcia
controller. So, I copied the whole distribution to a FAT32
partition via SMB and tried to do an install using the
distribution on that partition.
It failed with the error message saying that it couldn't
find the distribution files/directories, so the quick
workaround I used was to copy the whole install tree from
the FAT32 partition to an ext2 partition, and fixed the case
of the RPMS directory. This turned out to be a way overkill
as some investigating showed.

I spent several hours today trying to find out exactly what
the problem was, and how it could be fixed, so that others
could benefit from those findings and so that you could fix
it for RH 6.0

Let's see what's exactly happening:
RPMS is a name less than 8 chars, fully in uppercase.
Windows stores is as an "old" 8+3 name. The problem is that
linux's vfat system is based on the fat subsystem, which
shows such names in lowercase because it just "looks nicer"
on linux.
Once running under linux, you can actually do mv rpms tmp;
mv tmp RPMS and then you'll see the directory in uppercase
in linux, but the way this is done is by storing this as a
long filename.

Workaround:
once RH complains about not finding the installation tree,
if /tmp/hdimage is umounted, mknod hda1; mount -t vfat
hdimage
If it is mounted, I think it has to be unmounted (the
floppy's mount doesn't seem to support mount -wo remount
/tmp/hdimage) first, and then remounted
Then: cd /dir/to/RedHat; mv rpms tmp; mv tmp RPMS
and after that the installation should work as planned

Ugly fix:
Patch the installer to look both in RedHat/rpms and
RedHat/RPMS. A better fix would be to have a mount option to
give to the vfat module and tell it to leave filenames
without an aossociated LFN in uppercase.
Comment 1 David Lawrence 1998-11-29 20:33:59 EST
This bug has been verified. We are currently working on a solution.
Comment 2 Brian Ryner 1998-11-30 09:24:59 EST
I didn't even get to the point where you can specify the directory to
look in -- the FAT32 partition did not appear on the list of available
partitions to install from at all.  Possibly related to the fact that
Disk Druid didn't seem to recognize the partition type id (showed the
hex code, which fdisk said corresponded to "Win95 FAT32").  I used the
extremely ugly workaround of temporarily changing the partition type
id to fat16.
Comment 3 Matt Wilson 1998-12-09 17:17:59 EST
A fix is in testing.


*** This bug has been marked as a duplicate of 32 ***

Note You need to log in before you can comment on or make changes to this bug.