Bug 211072 - bad default config file
bad default config file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update 212953
  Show dependency treegraph
 
Reported: 2006-10-17 00:49 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.6.10-1.fc6.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 05:10:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config file for hplip service (444 bytes, application/octet-stream)
2006-10-26 12:53 EDT, Brian G. Anderson
no flags Details

  None (edit)
Description Brian G. Anderson 2006-10-17 00:49:34 EDT
Description of problem:
when my fc6 development machine shuts down I always get a hpssd shutdown
[FAILED] warning.  The /var/log/messages file shows this error message; 

Oct 16 21:41:44 porco python: hpssd[5024] error: Server exited with error: Unabl
e to bind to socket


Version-Release number of selected component (if applicable):
hplip-1.6.7-4

How reproducible:
always

Steps to Reproduce:
1. run "service hplip restart"
2.
3.
  
Actual results:
get a shutdown [FAILED] message when stopping hplip.

Expected results:
No message

Additional info:
Comment 1 Tim Waugh 2006-10-24 07:53:04 EDT
Do you still see this?  I did a few days ago but haven't since.
Comment 2 Brian G. Anderson 2006-10-25 18:35:13 EDT
Yes,  I just did a fresh install of FC6 on my laptop and when I shut down or
restart the service,  I get that message.

The /var/log/messages log shows:
hpssd[2909] error: Server exited with error: Unable to bind to socket

it doesn't seem to be an selinux problem since I can turn setenforce 0 and still
see the message.
Comment 3 Tim Waugh 2006-10-26 07:57:27 EDT
1. What does 'netstat -tlp' say, as root?
2. Also, please attach your /etc/hp/hplip.conf file (should be the same as mine..)
Comment 4 Brian G. Anderson 2006-10-26 12:52:14 EDT
I'll attach the hplip.conf after this. netstat syas:

[bikehead@porco ~]$ sudo netstat -tlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address            
State       PID/Program name   
tcp        0      0 localhost:2208              *:*                        
LISTEN      2141/hpiod          
tcp        0      0 *:sunrpc                    *:*                        
LISTEN      1864/portmap        
tcp        0      0 localhost:smtp              *:*                        
LISTEN      2104/sendmail: acce 
tcp        0      0 *:793                       *:*                        
LISTEN      1883/rpc.statd      
tcp        0      0 *:ssh                       *:*                        
LISTEN      2073/sshd           
tcp        0      0 porco:ipp                   *:*                        
LISTEN      2064/cupsd          
Comment 5 Brian G. Anderson 2006-10-26 12:53:33 EDT
Created attachment 139488 [details]
config file for hplip service

I've never changed this file, so this should be stock.
Comment 6 Tim Waugh 2006-10-27 10:16:09 EDT
The config parser is failing to convert '2207 (IANA IP Port)' to an int. 
Default config file needs fixing.
Comment 7 Tim Waugh 2006-10-31 06:26:40 EST
Please try this test update:

  https://www.redhat.com/archives/fedora-test-list/2006-October/msg01025.html

You should be able to do this using:

  yum --enablerepo=updates-testing update hpijs hplip libsane-hpaio
Comment 8 Fedora Update System 2006-11-01 14:27:18 EST
Errata pushed: hplip-1.6.10-1.fc6.4

Note You need to log in before you can comment on or make changes to this bug.