Bug 211097 - latest rawhide kernel broke xenguest-install / virt-manager
latest rawhide kernel broke xenguest-install / virt-manager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
: 211118 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 08:38 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2006-10-17 08:38:14 EDT
Description of problem:
xen-guestinstall and virt-manager don't work with latest rawhide kernel
2.6.18-1.2798.fc6xen, but work on the same machine when I boot into the older
2.6.18-1.2747.fc6xen kernel.

Version-Release number of selected component (if applicable):
virt-manager-0.2.3-2.fc6
xen-3.0.2-44
2.6.18-1.2798.fc6xen

How reproducible:
always 

Steps to reproduce:
1. start with 2.6.18-1.2798.fc6xen
2. run xen-guestinstall:
# xenguest-install 
Would you like a fully virtualized guest (yes or no)?  This will allow you to
run unmodified operating systems. yes

Traceback (most recent call last):
  File "/usr/sbin/xenguest-install", line 396, in ?
    main()
  File "/usr/sbin/xenguest-install", line 327, in main
    guest = virtinst.FullVirtGuest()
  File "/usr/lib/python2.4/site-packages/virtinst/FullVirtGuest.py", line 30, in
__init__
    XenGuest.XenGuest.__init__(self, hypervisorURI=hypervisorURI)
  File "/usr/lib/python2.4/site-packages/virtinst/XenGuest.py", line 174, in
__init__
    self.conn = libvirt.open(hypervisorURI)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 39, in open
    if ret is None:raise libvirtError('virConnectOpen() failed')
libvirt.libvirtError: virConnectOpen() failed

Same error happens when I type "no". virt-manager ask for the host to connect to
and that end without further error-messages.
Comment 1 Daniel Veillard 2006-10-17 09:09:54 EDT
Just to be sure, what version of libvirt and libvirt-python do you have
installed ?

Daniel
Comment 2 Thorsten Leemhuis 2006-10-17 09:15:08 EDT
libvirt-0.1.7-2
libvirt-python-0.1.7-2

BTW, you can find me as thl in #fedora-devel if needed
Comment 3 Stephen Tweedie 2006-10-17 09:38:08 EDT
Reproduced here: xend fails to start, with  

File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line 18,
in xshandle
  xs_handle = xen.lowlevel.xs.xs()
Error: (111, 'Connection refused')

errors in xend.log.  

2.6.18-1.2784.fc6xen works with the same userland.
Comment 4 Thorsten Leemhuis 2006-10-17 09:52:31 EDT
(In reply to comment #3)
> 2.6.18-1.2784.fc6xen works with the same userland.

Well, just guessing, but those changes look like the culprit to me:

rpm -q kernel-xen-2.6.18-1.2798.fc6 --changelog | less
[...]
* Sa Okt 14 2006 Juan Quintela <quintela@redhat.com> 
- update xen HV cset 11740.
- xen kernel update:
  * linux-2.6-xen-fedora changeset:   36227:84594d199837
  * xen-3.0.3-testing changeset:   11740:64b3e8596dc9
  * linux-2.6-xen-3.0.3 changeset:   22940:410c17270c74
  * remove all the blktap patches already included upstream.
[...]
Comment 5 Daniel Veillard 2006-10-17 12:25:35 EDT
*** Bug 211118 has been marked as a duplicate of this bug. ***
Comment 6 Stephen Tweedie 2006-10-17 13:44:02 EDT
Should be fixed in xen-3.0.3-0.1.rc3
Comment 7 das_deniz 2006-10-18 12:37:59 EDT
confirmed fix - excellent - thank you.
Comment 8 Thorsten Leemhuis 2006-10-18 12:51:51 EDT
Agreed, thx everyone!

Note You need to log in before you can comment on or make changes to this bug.