Bug 211149 - Kernel panic on PXE boot on IBM t60p
Kernel panic on PXE boot on IBM t60p
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 13:55 EDT by Richard Li
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Li 2006-10-17 13:55:57 EDT
Description of problem:

On PXE boot, the kernel panics before the installer gets started. Will post full
error message in next comment.

Version-Release number of selected component (if applicable):

2.6.18-1.2717.el5


How reproducible:

Always.

Hardware:

IBM Thinkpad T60p

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2500  @ 2.00GHz
stepping        : 8
cpu MHz         : 1995.097
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat clflush dts
acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pni monitor vmx est tm2 xtpr
bogomips        : 4991.21




00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (re
v 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA
 Storage Controller AHCI (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc M56GL [ATI Mobility Fire
GL V5200]
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controlle
r
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Conne
ction (rev 02)
15:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
Comment 1 Richard Li 2006-10-17 14:00:57 EDT
Error message:

md: autorun ...
md: ... autorun DONE.
EXT2-fs: unable to read superblock
isofs_fill_super: bread failed, dev=md1, iso_blknum16, block=32
No filesystem could mount root, tried: ext2 iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,1)
Comment 2 RHEL Product and Program Management 2006-10-17 18:04:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Jeff Needle 2006-10-17 18:24:41 EDT
This looks identical to the crash that jrb got on his t60p yesterday using the
1002 tree (kernel-2.6.18-1.2704.el5).  We redid the install on the engineering
VLAN using the 20061012 tree, which is the same kernel as used here, and it
installed correctly.  I wonder if there's something unique to the corporate vlan
pxe server that's causing this.  As far as I know, the PXE configs are identical
for both VLANs now.
Comment 5 Richard Li 2006-10-18 08:55:08 EDT
I don't think it's a corp VLAN problem because:

1. Zack was able to PXE install on this same laptop with the B1 tree from the
corp VLAN.
2. Zack was also able to PXE install on a different laptop with the 2717 kernel
yesterday.

Since it doesn't take that long to reproduce, perhaps we should backtrack
through the different milestone kernels to see if we can narrow down the
regression? Of course, there are a lot of patches going in daily so not sure if
that will help.
Comment 6 Tom Kincaid 2006-10-18 09:01:00 EDT
This binary search approach will be time consuming. Even if we do identify which
milestone build it appeared in, getting the exact patch will be a decent amount
of effort as well.

We may have no choice but to go that way. However, as an additional data point,
Richard can you try installing off the Engineering VLAN.

Jeff does Engineering VLAN == Dogfood Network?

Tom
Comment 7 Richard Li 2006-10-18 09:04:35 EDT
I'm traveling the rest of the week, but the laptop is sitting on my desk if
someone wants to try it (hit F12 at the boot screen to bring up the boot menu).

I agree the binary search is time consuming. The good news, though, is that I
estimate it will be a 5 minute cycle to check a single tree. So it's not
TERRIBLE, just extremely tedious :-).

If no one can test it out this week, I will get to it next week.
Comment 8 Jonathan Blandford 2006-10-18 11:45:22 EDT
I was able to install RHEL fine on the engineering vlan on the T60p.
Comment 9 Richard Li 2006-10-18 11:46:28 EDT
which kernel?
Comment 10 Jonathan Blandford 2006-10-18 11:49:32 EDT
(Forgot to add, I'm running kernel-2.6.18-1.2717.el5 )
Comment 11 Jeff Needle 2006-10-18 15:18:20 EDT
This was a typo on the initrd line on the corporate PXE server.  All fixed now.
 Closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.