Bug 2111701 - bulk remote execution fails with 404 Not FoundError loading data from Capsule: NoMethodError - undefined method `code' for "404 Not Found":String
Summary: bulk remote execution fails with 404 Not FoundError loading data from Capsule...
Keywords:
Status: CLOSED DUPLICATE of bug 2106700
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Remote Execution
Version: 6.11.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Satellite QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-27 22:22 UTC by Kenny Tordeurs
Modified: 2023-05-19 09:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-19 09:34:45 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Kenny Tordeurs 2022-07-27 22:22:10 UTC
Description of problem:
Bulk rex commands fail with:
~~~
 1: Initialization error: RestClient::NotFound - 404 Not Found
 2: Initialization error: RestClient::NotFound - 404 Not Found
 3: Initialization error: RestClient::NotFound - 404 Not Found
 4: Initialization error: RestClient::NotFound - 404 Not FoundError loading data from Capsule: NoMethodError - undefined method `code' for "404 Not Found":String
   5: Did you mean?  encode
~~~

Version-Release number of selected component (if applicable):
6.11.1

How reproducible:
100&

Steps to Reproduce:
1. run rex ssh job against several hosts
2.
3.

Actual results:
 1:
Initialization error: RestClient::NotFound - 404 Not Found
   2:
Initialization error: RestClient::NotFound - 404 Not Found
   3:
Initialization error: RestClient::NotFound - 404 Not Found
   4:
Initialization error: RestClient::NotFound - 404 Not FoundError loading data from Capsule: NoMethodError - undefined method `code' for "404 Not Found":String
   5:
Did you mean?  encode

Expected results:
no issues

Additional info:
single rex job to 1 host works

Comment 1 Kenny Tordeurs 2022-07-27 22:22:39 UTC
Error looks exact match for https://community.theforeman.org/t/finished-get-dynflow-tasks-status-with-404/27226

Comment 2 Adam Ruzicka 2022-07-28 07:05:27 UTC
Also matches this https://bugzilla.redhat.com/show_bug.cgi?id=2106700

Could you refresh feature on the capsule and check that it has all the necessary features for the rex you're trying to do. Also, could we get logs?

Comment 3 Kenny Tordeurs 2022-07-28 09:10:32 UTC
There are 2 capsules in this environment:
- 1 external capsule (is being used by almost none of the clients)
- 1 integrated capsule (almost all the clients are connected to this)

Running the REX against 1 host at a time works fine.

Comment 8 Adam Ruzicka 2023-05-19 09:34:45 UTC
We haven't heard any other reports of this and I haven't found any conclusive evidence in the sosreport, which would lead me to believe this was a different flavor of https://bugzilla.redhat.com/show_bug.cgi?id=2106700 . I'll go ahead and close this as a duplicate, feel free to reopen if it shows up again.

*** This bug has been marked as a duplicate of bug 2106700 ***


Note You need to log in before you can comment on or make changes to this bug.