Bug 211184 - Update to libc-client2006.i386 2006a-4.fc5 breaks pine spool copying
Update to libc-client2006.i386 2006a-4.fc5 breaks pine spool copying
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: uw-imap (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://www.webservertalk.com/archive6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 15:31 EDT by Eric
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2006b-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 15:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric 2006-10-17 15:31:57 EDT
Description of problem:
On Oct 7, I did my usual yum update, and one of the updates was for 
libc-client2006.i386 2006a-4.fc5.  The previous day, yum updated pine.i386
4.64-3.lvn5 from Livna (obviously), which installed libc-client2006.i386
2006a-1.fc5.  After that, pine wouldn't move mail from /var/spool/mail/$USER to
/home/$USER/mbox ; it would only read directly from /var/spool/mail/$USER.  I
have since updated to libc-client2006.i386 2006b-1.fc5 (Oct 13), and installed
uw-imap-utils-2006b-1.fc5 today (Oct 17).  I had also tried reinstalling pine,
as well as libc-client2006.  Still wasn't working.  I then found some postings
by the UW folks, and they mentioned the /etc/c-client.cf file...apparently the

set mail-subdirectory Mail

line was causing trouble and interfering with pine's operation.  I commented out
that line and it fixed my problem (deleting the file also fixed it).  I don't
know if that was actually fixed in a later update, but that file was never
manually removed or fixed, but the file timestamp--as you can see--was a couple
days before that yum update...

[root@bilbo ~]# ls -al /etc/c-client.cf
-rw-r--r-- 1 root root 99 Oct  4 14:11 /etc/c-client.cf
[root@bilbo ~]# cat /etc/c-client.cf
I accept the risk of using UW-IMAP
set new-folder-format same-as-inbox
set mail-subdirectory Mail


Version-Release number of selected component (if applicable):
libc-client2006.i386 2006a-4.fc5

How reproducible:
Not sure...only one computer to test it on, and now that I have it working, I'm
not going to mess it up again.

Steps to Reproduce:
1. Install pine
2. Update pine to pine.i386 4.64-3.lvn5, which installs libc-client2006.i386
2006a-4.fc5
3. When pine runs, it doesn't move from spool file
Comment 1 Rex Dieter 2006-10-17 15:40:12 EDT
Yup, this is precisely what the libc-client2006-2006b-1 update fixes.  Sorry for
the troubles.

%changelog
* Fri Oct 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 2006b-1
- imap-2006b
- %%ghost %%config(missingok,noreplace) %%{_sysconfdir}/c-client.cf


Comment 2 Rex Dieter 2006-10-17 15:45:41 EDT
See also pine bugs with recent relevant activity:
http://bugzilla.livna.org/show_bug.cgi?id=1184#c18 (comment 18 to the end)
and
http://bugzilla.livna.org/show_bug.cgi?id=1187
Comment 3 Eric 2006-10-17 16:08:21 EDT
(In reply to comment #1)
> %changelog
> * Fri Oct 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 2006b-1
> - imap-2006b
> - %%ghost %%config(missingok,noreplace) %%{_sysconfdir}/c-client.cf
> 

Yeah, I saw that in the changelog, but I'm not familiar with the RPM build
process, so I wasn't sure what that did (especially since I still had the file
hanging around).  Anyway, no big deal; this isn't a production server or
anything, just my home machine.  Thanks for the prompt response and whatnot.

Note You need to log in before you can comment on or make changes to this bug.