This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 211197 - xenoprofile uses incorrect mode and eip/rip for AMD-V
xenoprofile uses incorrect mode and eip/rip for AMD-V
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Markus Armbruster
: OtherQA
Depends On:
Blocks: 252354 212366 221316
  Show dependency treegraph
 
Reported: 2006-10-17 16:17 EDT by Tom Woller
Modified: 2009-06-19 05:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:13:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
1/3 patch for 3.0.3 xenoprofile AMD-V mode eip/rip fix. (961 bytes, patch)
2006-10-17 16:17 EDT, Tom Woller
no flags Details | Diff
2/3 patch for 3.0.3 xenoprofile AMD-V mode eip/rip fix. (3.17 KB, application/octet-stream)
2006-10-17 16:21 EDT, Tom Woller
no flags Details
3/3 patch for 3.0.3 xenoprofile AMD-V mode eip/rip fix. (979 bytes, patch)
2006-10-17 16:22 EDT, Tom Woller
no flags Details | Diff
Upstream version of the patch (xen-unstable.hg changesets 11843 and 11844) (8.44 KB, patch)
2006-10-26 10:18 EDT, Markus Armbruster
no flags Details | Diff

  None (edit)
Description Tom Woller 2006-10-17 16:17:56 EDT
Description of problem:
THe mode and eip/rip are not properly updated for HVM guests for AMD-V.  The 
attached patches modify AMD-V specific code, and add a generic xenoprofile 
function for HVM.  These patches have not been pushed up to xen-unstable.hg, 
but will be when the tree reopens after 3.0.3 is released.  

Version-Release number of selected component (if applicable):
All xen versions have this bug.

How reproducible:
run xenoprofile 0.9.2 with additional patch from HP (Renato Santos) to enable 
passive profiling.

Steps to Reproduce:
1. start up hvm guest on AMD-V machine
2. run xenoprofile 0.9.2 w/ passive patch
3. the profiling records will be incorrect (wrong symbol matches)
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom Woller 2006-10-17 16:17:56 EDT
Created attachment 138715 [details]
1/3 patch for 3.0.3 xenoprofile AMD-V mode eip/rip fix.
Comment 2 Tom Woller 2006-10-17 16:21:04 EDT
Created attachment 138717 [details]
2/3 patch for 3.0.3 xenoprofile AMD-V mode eip/rip fix.
Comment 3 Tom Woller 2006-10-17 16:22:25 EDT
Created attachment 138718 [details]
3/3 patch for 3.0.3 xenoprofile AMD-V mode eip/rip fix.
Comment 4 Brian Stein 2006-10-19 13:42:55 EDT
Please attach the changeset once this is submitted in -unstable.  We will
include this after Beta 2.
Comment 5 Tom Woller 2006-10-20 14:34:51 EDT
the xenoprofile HVM support is now in the xen-unstable tree.
please use changesets 11843 and 11844 from xen-unstable.hg for the latest 
patches.
Comment 6 RHEL Product and Program Management 2006-10-20 15:04:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 7 Brian Stein 2006-10-25 10:46:36 EDT
Does this patch require the HP xenoprofile patch to be relevant?
Comment 8 Tom Woller 2006-10-25 13:15:34 EDT
just to be clear, the HP patch is only used for the application oprofile, but 
the answer is yes.  basically, to perform passive profiling for HVM guests 
properly you need to have the AMD-V patches from xen-unstable incorporated 
into your hypervisor, and also the oprofile-0.9.2+HP patch for the Dom0 
application level opreport/opcontrol apps.  0.9.3 should be out soon with this 
patch integrated.
Comment 9 Tom Woller 2006-10-25 13:16:35 EDT
just to be clear, the HP patch is only used for the application oprofile, but 
the answer is yes.  basically, to perform passive profiling for HVM guests 
properly you need to have the AMD-V patches from xen-unstable incorporated 
into your hypervisor, and also the oprofile-0.9.2+HP patch for the Dom0 
application level opreport/opcontrol apps.  0.9.3 should be out soon with this 
patch integrated.
Comment 10 Markus Armbruster 2006-10-26 10:18:15 EDT
Created attachment 139462 [details]
Upstream version of the patch (xen-unstable.hg changesets 11843 and 11844)
Comment 11 Tom Woller 2006-10-26 15:38:11 EDT
The attached patches from xen-unstable 11843 and 11844 are functionally 
correct.
Comment 12 Bhavna Sarathy 2006-11-07 15:39:21 EST
Here's the user space patch link:

A XenOprofile patch for Oprofile 0.9.2 is now available at
http://xenoprof.sourceforge.net.
Oprofile 0.9.2 already supports XenOprofile but it does not include
support for passive domain profiling.
This patch adds passive domain profiling support to Oprofile 0.9.2. 
Comment 14 Jay Turner 2006-11-20 15:09:16 EST
QE ack for RHEL5.
Comment 15 Markus Armbruster 2006-12-18 14:36:59 EST
Bhavana Nagendra reports that xen-unstable.hg changeset 12667 is also needed. 
Posted, awaiting ACKs.
Comment 17 Bhavna Sarathy 2007-01-02 15:32:20 EST
I'm adding these notes regarding testing to set expectations.   There are more
than 20+ xenoprof patches upstream which are required to completely get xenoprof
to work.   Out of these we have identified 3 patches that have the most impact.
  Running some known scripts utilizing opcontrol/opreport the hypervisor
generates some good samples.   There are some errors but these are expected as
the RHEL5 code base is missing a number of patches.   We will target RHEL5.1 for
the remaining patches, but the submitted patches needs to be included in RHEL5
RC snapshot 6.

Comment 18 Markus Armbruster 2007-01-04 10:56:41 EST
Release note:
Profiling of fully virtual domains may be inaccurate.  This will
be addressed in a future update of Red Hat Enterprise Linux 5.
Comment 19 Brian Stein 2007-01-04 11:20:39 EST
Too many patches for GA inclusion, pushing to 5.1.
Comment 21 Bhavna Sarathy 2007-01-29 13:56:59 EST
Version flag needs to be modified to reflect that this is a RHEL5.1 requirement
Comment 22 Brian Stein 2007-01-29 14:03:46 EST
Flags continue to be correctly set.
Comment 23 Markus Armbruster 2007-06-20 15:53:08 EDT
Switching to MODIFIED because the rebase to a 3.1 hypervisor took care of this.
 More changes are needed for a fully functional Xenoprof, but those are tracked
in bug 241982.
Comment 25 John Poelstra 2007-08-27 14:17:49 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot3 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 26 John Poelstra 2007-08-30 20:28:58 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot4 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed *as soon as possible*
to ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 27 John Poelstra 2007-09-11 15:22:01 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot6 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 28 John Poelstra 2007-09-20 00:47:28 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot7 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 29 John Poelstra 2007-09-26 19:44:56 EDT
A fix for this issue should be included in the packages contained in
RHEL5.1-Snapshot8--available now on partners.redhat.com.  

IMPORTANT: This is the last opportunity to confirm that your issue is fixed in
the RHEL5.1 update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 31 errata-xmlrpc 2007-11-07 14:13:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.