Bug 21120 - Kernel fail to compile
Summary: Kernel fail to compile
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-20 13:40 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 22:15:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-20 13:40:30 UTC
The kernel from a Rh 7.0 out of the box fail to compile, it seems to be 
some problem with the smp support 
Extract from a make bzImage:
 /src/linux/include/asm/softirq.h:75: warning: `synchronize_bh' redefined
/usr/src/linux/include/linux/modules/i386_ksyms.ver:142: warning: this is 
the lo
cation of the previous definition
/usr/src/linux/include/linux/kernel_stat.h: In function `kstat_irqs':
In file included from ksyms.c:17:
/usr/src/linux/include/linux/kernel_stat.h:47: `smp_num_cpus' undeclared 
(first
use in this function)
/usr/src/linux/include/linux/kernel_stat.h:47: (Each undeclared identifier 
is re
ported only once
/usr/src/linux/include/linux/kernel_stat.h:47: for each function it 
appears in.)
/usr/src/linux/include/linux/kernel_stat.h:48: warning: implicit 
declaration of
function `cpu_logical_map'
/usr/src/linux/include/asm/softirq.h: In function `start_bh_atomic':
In file included from /usr/src/linux/include/linux/interrupt.h:52,
                 from ksyms.c:21:
/usr/src/linux/include/asm/softirq.h:62: warning: implicit declaration of 
functi
on `smp_processor_id'
make[2]: *** [ksyms.o] Error 1

Comment 1 Arjan van de Ven 2000-11-20 15:27:59 UTC
Dupe.
You probably changed the .config from SMP to UP. In that case, you have to
issue a "make mrproper" before compiling your kernel. (Be careful, make mrproper 
also deletes the .config file, so copy that to a safe location before the
command and copy it back later). Be sure to run "make oldconfig" after you
copied your .config file back.

This is a known, but very hard to solve correctly, bug in the 2.2 series
kernels. 


Comment 2 Need Real Name 2000-11-20 22:15:38 UTC
It seems that the RH7.0 kernel-source package defaults to SMP (in that the 'make
mrproper' above is required) even though the config defaults to uniprocessor. 
So perhaps the right solution is a cleaned up kernel-source package?

Comment 3 Bill Nottingham 2000-11-22 05:44:13 UTC
No, the module symbols are there for building external modules against.

Comment 4 Need Real Name 2000-11-22 11:12:59 UTC
It has nothing to do with the kernel package, I downloaded from kernel.org the 
lastest 2.2.17 and a previous 2.2.15 and both had the same error, I did what 
arjan@fenrus.demon.nl pointed above and the kernel compiled fine, but I'm not 
be able to compile the modules, so I had to make a monolitic kernel


Note You need to log in before you can comment on or make changes to this bug.