Bug 211211 - "ata1: port is slow to respond, please be patient" followed by failures
"ata1: port is slow to respond, please be patient" followed by failures
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: FCMETA_SATA 216740
  Show dependency treegraph
 
Reported: 2006-10-17 16:58 EDT by Dave Malcolm
Modified: 2013-07-02 22:30 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 16:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from the boot (17.81 KB, text/plain)
2006-10-17 16:58 EDT, Dave Malcolm
no flags Details
dmesg (20.53 KB, text/plain)
2006-10-18 10:22 EDT, John Holmstadt
no flags Details
/var/log/messages.log (29.40 KB, text/plain)
2006-10-24 13:03 EDT, Beeba
no flags Details
/var/log/messages output with SATA2 disabled, OS HDD on SATA 0 (33.96 KB, text/plain)
2006-10-27 11:49 EDT, Dan Walkes
no flags Details
dmesg with ata[12] timeouts on Dell Optiplex GX270N. SATA disabled in BIOS. No SATA disks attached to the system. (16.90 KB, text/plain)
2006-10-30 18:26 EST, Diego Novillo
no flags Details
dmesg output before I applied the kernel parameter (21.27 KB, text/plain)
2007-10-24 05:07 EDT, Willie Engelbrecht
no flags Details
dmesg output after I applied the kernel parameter (20.49 KB, text/plain)
2007-10-24 05:12 EDT, Willie Engelbrecht
no flags Details

  None (edit)
Description Dave Malcolm 2006-10-17 16:58:22 EDT
Description of problem:
From the dmesg:
scsi0 : ata_piix
ata1: port is slow to respond, please be patient
ata1: port failed to respond (30 secs)
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: reset failed, giving up
scsi1 : ata_piix
ata2: port is slow to respond, please be patient
ata2: port failed to respond (30 secs)
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: reset failed, giving up


Version-Release number of selected component (if applicable):
Seen in kernel-2.6.18-1.2726.fc6 and kernel-xen-2.6.17-1.2630.fc6
Not seen in kernel-2.6.16-1.2208_FC6


How reproducible:
100%

Not sure how much of a problem this is; having other problems booting into a
usable system with this kernel.
Comment 1 Dave Malcolm 2006-10-17 16:58:23 EDT
Created attachment 138726 [details]
dmesg from the boot
Comment 2 Dave Malcolm 2006-10-17 17:00:59 EDT
(apart from delaying the boot whilst each waiting for each timeout, that is)
Comment 3 John Holmstadt 2006-10-18 10:21:38 EDT
I'm seeing this as well on a Dell Poweredge SC1420 with kernel version
2.6.18-1.2200. Everything appears to function just fine after it fails, it just
makes the boot process take an extra minute and a half to complete.
Comment 4 John Holmstadt 2006-10-18 10:22:48 EDT
Created attachment 138788 [details]
dmesg
Comment 5 Dave Malcolm 2006-10-19 14:03:37 EDT
FWIW the original report was also seen on a Dell, a GX270.
Comment 6 Jan Pazdziora 2006-10-24 05:10:48 EDT
The same problem in RHEL 5 Beta 2, on a Dell GX 270, kernel 2.6.18-1.2732.el5xen.
Comment 7 Beeba 2006-10-24 13:03:41 EDT
Created attachment 139240 [details]
/var/log/messages.log
Comment 8 Beeba 2006-10-24 13:05:43 EDT
Experiencing the same problems on Dell Precision 360, motherboard with both SATA
and ATA controllers, SATA disabled in BIOS, FC5 installed on ATA - /dev/hda6 -
kernel 2.6.18-1.2200 (both versions non-smp/smp). After cca 2-3 minutes of
reporting failures in reseting ata1 and ata2 boots normally, avahi daemon fails
to start, the rest is OK - see the attachment above.
Comment 9 Orion Poplawski 2006-10-26 13:18:38 EDT
Me too.  Dell Dimension 8300.  OS on ATA/IDE (/dev/hda).  SATA is probably
disabled in BIOS as well.

00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)

ata_piix 0000:00:1f.2: version 2.00
ata_piix 0000:00:1f.2: MAP [ P0 -- P1 -- ]
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0xFE00 ctl 0xFE12 bmdma 0xFEA0 irq 169
ata2: SATA max UDMA/133 cmd 0xFE20 ctl 0xFE32 bmdma 0xFEA8 irq 169
scsi0 : ata_piix
ata1: port is slow to respond, please be patient
ata1: port failed to respond (30 secs)
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: reset failed, giving up
scsi1 : ata_piix
ata2: port is slow to respond, please be patient
ata2: port failed to respond (30 secs)
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: reset failed, giving up


Comment 11 Dan Walkes 2006-10-27 11:49:31 EDT
Created attachment 139588 [details]
/var/log/messages output with SATA2 disabled, OS HDD on SATA 0
Comment 12 Dan Walkes 2006-10-27 11:51:12 EDT
Same noticed with Dell Optiplex GX280 (Intel ICH6 82801FB.)  Fedora 6 install. 
OS HDD is on SATA 0.  Happens even when SATA2 (only other port) is disabled in 
the BIOS (BIOS Rev A08.)

uname -a:
Linux hwqual 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 i686 
i386 GNU/Linux

..
Oct 27 09:28:40 hwqual kernel: ata2: port is slow to respond, please be patient
Oct 27 09:28:40 hwqual kernel: ata2: port failed to respond (30 secs)
Oct 27 09:28:40 hwqual kernel: ata2: SRST failed (status 0xFF)
..

full /var/log/message output attached (see previous post)
Comment 13 Diego Novillo 2006-10-30 18:23:25 EST
Likewise on a Dell OptiPlex GX270N.  There are no SATA disks connected to the
machine and SATA support is disabled in BIOS.  System hangs for about a minute
waiting for timeouts on ata1 and ata2.

Kernel: 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006
dmesg output coming up
Comment 14 Diego Novillo 2006-10-30 18:26:20 EST
Created attachment 139782 [details]
dmesg with ata[12] timeouts on Dell Optiplex GX270N.  SATA disabled in BIOS.  No SATA disks attached to the system.
Comment 15 Will Woods 2007-04-19 15:46:51 EDT
This used to affect my Dell machine, but has since gone away. Is this fixed for
you, Dave?
Comment 16 Walt Smith 2007-05-04 18:51:54 EDT
ata2:00 error msg on FC7T4 CDlive boot with non-kde liveCD
followed by hang and/or kernel panic.

I List 5 boxes tested.
--

first release of FC7 test 4 used.
all boxes used the same physical CDLive CD.
5 boxes listed, 3 do not boot, 2 will boot to gui properly.

---
List of boxes tested and did not complete boot
with same error msg:

Gateway 
model: GP7-6676   LP Mini tower mfg date 2000
ser#: 0019209881
667 mhz   512 meg ram, ide drive, no ata

--

Dell
model poweredge 1400SC  MMP  mfg date 2003
ser#: F135821
1.4 ghz  512 ram
no scsi drives, no ata drive, RAID PCB removed, ide drive 

--

Generic Box
Intel MB   mfg about 2005/6
D865GLC/D865PESO  
ser# E210882 ( apparently )
2.8 ghz 512 meg
ide drive, no ata drive

--

List of boxes test which completed boot:

Dell 
Optiplex GX110   mfg 2000
Model: DCS
ser# G6RB01
667 mhz  512 meg
no ide drive, no ata IF

Gateway
Model:  MFATXPNT MDW E4100 E6000  mfg 2004
ser# 0032853623
2.6 ghz 512 meg
ide drive, no ata drive

---

note: I'm an "occasional" tester.
and followup for me would be difficult.
Because I lurk the archives, and don't test regularly,
the methods and info developers use is much of a mystery.

I provide this information for documentation purposes only.

walt.......
Comment 17 Andrew Case 2007-05-08 17:59:01 EDT
I have this problem on Dell GX620 with 1 SATA Hard drive and 1 IDE DVD+R/W
Comment 18 Walt Smith 2007-06-09 09:09:35 EDT
hello,
Of the 5 boxes I list above,
only the Dell Poweredge 1400SC
does -not- boot using the FC7 --final release-- 
LiveCD-gnome  CD media.

note that my Poweredge has the RAID card removed and
has no ATA drives.

walt ....

Comment 19 Willie Engelbrecht 2007-10-24 05:07:42 EDT
Created attachment 236051 [details]
dmesg output before I applied the kernel parameter
Comment 20 Willie Engelbrecht 2007-10-24 05:09:53 EDT
Hello

I have a Dell Optiplex 745 at my disposal, and I get the same SATA unused ports
error. The error I get is: 

ata1: port is slow to respond, this delay is known to occur on vacant SATA ports
ata1: port failed to respond (30 secs)
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: reset failed, giving up

and so on for every unused SATA port. 

I've found two workable solutions for this problem (which might be specific to
the Dell Optiplex 745).

 - Solution 1: In the BIOS, set the SATA operation to "legacy" mode, AND apply a
kernel parameter "all-generic-ide" (on the commandline and/or grub.conf). 

 - Solution 2: Installing Redhat 5.1 Beta (as of 24/10/2007) seems to not suffer
from the same problem. 

I am adding two attachments, one is the dmesg output before I apply the kernel
paramter (all-generic-ide), and one is for after I applied the kernel paramter.
(In both cases SATA operation was set to normal mode, which on its own doesn't
fix the SATA ports unused problem). 
Comment 21 Willie Engelbrecht 2007-10-24 05:12:40 EDT
Created attachment 236061 [details]
dmesg output after I applied the kernel parameter
Comment 22 Will Woods 2008-03-18 16:54:29 EDT
No response from original reporter, can't reproduce it on my affected systems. Assuming the problem has 
been fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.