Bug 21123 - console banner should report memory size
Summary: console banner should report memory size
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-20 14:53 UTC by Stig Hackvan
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 14:53:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stig Hackvan 2000-11-20 14:53:47 UTC
rc.local creates /etc/issue
it reports the processor speed, but not the memory size.

SINCE LINUX IS OFTEN TOO STUPID TO RECOGNIZE MORE THAN 64M OF MEMORY ON
IT'S OWN, IT IS A CRITICAL SANITY CHECK TO SHOW THE MEMORY SIZE ALONG WITH
THE PROCESSOR TYPE (it's at least as important for guaging system
performance, too).

--- rc.local~	Thu Sep 30 08:40:33 1999
+++ rc.local	Mon Nov 20 05:35:18 2000
@@ -28,7 +28,7 @@
     # want to make to /etc/issue here or you will lose them when you
reboot.
     echo "" > /etc/issue
     echo "$R" >> /etc/issue
-    echo "Kernel $(uname -r) on $a $SMP$(uname -m)" >> /etc/issue
+    echo "Kernel $(uname -r) on $a $SMP$(uname -m) with `sed -n
's/MemTotal: *//p'</proc/meminfo` of memory" >> /etc/issue
 
     cp -f /etc/issue /etc/issue.net
     echo >> /etc/issue

Comment 1 Bill Nottingham 2001-01-29 20:44:11 UTC
No, we're not going to change anything in rc.local
without a really good reason.

The new memory detection code in 2.4 should catch most of these
cases anyway.


Note You need to log in before you can comment on or make changes to this bug.