Bug 211234 - build-system needs to support building multiple archs from one tree
build-system needs to support building multiple archs from one tree
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2006-10-17 19:29 EDT by Nathan Kinder
Modified: 2015-12-07 12:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:18:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Fix (5.46 KB, patch)
2006-10-17 19:29 EDT, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nathan Kinder 2006-10-17 19:29:21 EDT
The new autotools-based DS build system needs to support for building multiple
architectures from one source tree.  This will allow us to do things like:

- Create arch directory and cd into it
- run configure and make from the arch directory

You should be able to repeat this for as many build architectures as you want
from one source tree.  We need to make sure that any files generated during the
build go into the build area, not the source area.

The following attachment makes the necessary changes to support the scenario
described above.  I have omitted the generated Makefile.in file since it is
generated directly from the attached Makefile.am changes by running autoreconf.
Comment 1 Nathan Kinder 2006-10-17 19:29:22 EDT
Created attachment 138734 [details]
Proposed Fix
Comment 2 Rich Megginson 2006-10-17 20:35:32 EDT
Looks good.  How do you use it?
Comment 3 Nathan Kinder 2006-10-18 11:29:18 EDT
There's really little difference in building with these changes.

Instead of running "./configure; make" inside the ldapserver directory, you
would create a subdirectory for the architecture you are building for (such as
"ldapserver/RHEL4_DBG").  You would then cd into the "RHEL4_DBG" directory and
run "../configure".  This will create the Makefile in the RHEL4_DBG directory,
so you would just run Make from there.  All of the built files will be placed in
the subdirectory that you created instead of in the checked out source tree.
Comment 4 Nathan Kinder 2006-10-18 12:34:37 EDT
Checked into ldapserver (HEAD).  Thanks to Rich for the review!
Comment 5 Nathan Kinder 2006-10-18 12:38:23 EDT
Checking in Makefile.am;
/cvs/dirsec/ldapserver/Makefile.am,v  <--  Makefile.am
new revision: 1.2; previous revision: 1.1
done
Checking in Makefile.in;
/cvs/dirsec/ldapserver/Makefile.in,v  <--  Makefile.in
new revision: 1.2; previous revision: 1.1
done
Comment 7 Nathan Kinder 2007-12-21 13:02:21 EST
We have been successfully building using this method in the nightlies for a long
time now.  Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.