Bug 211238 - Cluster node reboot debug option for clumanager
Cluster node reboot debug option for clumanager
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 20:07 EDT by Xixi
Modified: 2009-04-16 16:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0165
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 08:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reboot debug patch (5.59 KB, patch)
2006-10-17 20:07 EDT, Xixi
no flags Details | Diff
Newer patch (8.89 KB, patch)
2007-01-11 16:13 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Comment 12 Kiersten (Kerri) Anderson 2007-01-11 13:02:59 EST
Devel and QE ACK since Lon does the QA on this version of the product.
Comment 14 Lon Hohberger 2007-01-11 16:13:46 EST
Created attachment 145393 [details]
Newer patch

Makes the process calling do_reboot() the highest-priority thing on the system.
Comment 19 Lon Hohberger 2007-05-21 14:04:12 EDT
Testing: See opening description
Comment 21 Lon Hohberger 2007-05-21 16:28:41 EDT
Set reboot_debug to yes and ripped out the SCSI cables on my RHEL3 cluster:

[root@yellow root]# cat /tmp/clumanager-reboot-debug 
Mon May 21 15:09:36 2007
-> reboot(19088743) @ shared_services.c:186 in function disk_error_action()
Comment 23 Red Hat Bugzilla 2007-06-14 08:53:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0165.html

Note You need to log in before you can comment on or make changes to this bug.