Bug 211244 - RAWHIDE: xenguest-install and virt-manager will not install new OS's
RAWHIDE: xenguest-install and virt-manager will not install new OS's
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 211276
  Show dependency treegraph
 
Reported: 2006-10-17 21:45 EDT by Josef Bacik
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 16:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2006-10-17 21:45:26 EDT
Description of problem:
If you try to use virt-manager or xenguest-install to install a new XEN guest it
fails when it tries to do the install.  

[root@dhcp59-101 ~]# xenguest-install 
Would you like a fully virtualized guest (yes or no)?  This will allow you to
run unmodified operating systems. yes
 What is the name of your virtual machine? system1
 How much RAM should be allocated (in megabytes)? 256
 What would you like to use as the disk (path)? /dev/my_test_vg/xen_store1 
 Would you like to enable graphics support? (yes or no) yes
 What would you like to use for the virtual CD image?
/mnt/archives/released/RHEL-4/U4/AS/x86_64/RHEL4-U4-re20060802.1-x86_64-AS-DVD-ftp.iso

 

Starting install...
libvir: Xen Daemon error : GET operation failed: No such domain system1
libvir: Xen Daemon error : POST operation failed: (xend.err 'Error creating
domain: HVM guest support is unavailable: is VT/AMD-V supported by your CPU and
enabled in your BIOS?')
Failed to create domain system1
Traceback (most recent call last):
  File "/usr/sbin/xenguest-install", line 396, in ?
    main()
  File "/usr/sbin/xenguest-install", line 360, in main
    dom = guest.start_install(conscb)
  File "/usr/lib/python2.4/site-packages/virtinst/XenGuest.py", line 355, in
start_install
    self.domain = self.conn.createLinux(cxml, 0)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 249, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed')
libvirt.libvirtError: virDomainCreateLinux() failed


Version-Release number of selected component (if applicable):
[root@dhcp59-101 ~]# rpm -q libvirt libvirt-python xen
libvirt-0.1.8-1
libvirt-python-0.1.8-1
xen-3.0.3-0.1.rc3

How reproducible:
Always

Steps to Reproduce:
1.Try to create a new xen guest using xenguest-install or virt-manager
2.
3.
  
Actual results:
You get an error message, or a traceback in the case of xenguest-install

Expected results:
Should continue with the install

Additional info:
Comment 1 Josef Bacik 2006-10-17 22:09:54 EDT
ahh ok well i just actually read the traceback so I assume its happening b/c I
select "Fully Virtualized" and it says I dont ahve the capabilities, but I do

[jwhiter@dhcp59-101 ~]$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Genuine Intel(R) CPU                  @ 1.86GHz
stepping        : 5
cpu MHz         : 1861.965
cache size      : 4096 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush
dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor
ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips        : 4656.60
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

I have the vmx flag which is the flag i need for it to be fully virtualized right?
Comment 2 Daniel Berrange 2006-10-18 08:30:22 EDT
As per the error message shown in comment #1, merely having VMX flag in the CPU
is not sufficient. You must also ensure it is enable in the BIOS.

That said, the 'virtinst' package should be checking this too - the code only
checks the CPU flags currently, but should also check the MSR, or xen
capabilities flags & not traceback.
Comment 3 Josef Bacik 2006-10-18 10:50:42 EDT
Ok now when I create the guest with virt-manager, it will hang for a little 
bit, and then spit out an error, but it actually creates the guest from what I 
can tell.  I will redo with xmguest-install and see if it spits out anything 
more usefull.  btw I've enabled the virtualization stuff in the bios 
 
[root@dhcp59-101 ~]# cat /sys/hypervisor/properties/capabilities   
xen-3.0-x86_64 hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64  
 
Comment 4 Josef Bacik 2006-10-18 10:55:29 EDT
[root@dhcp59-101 ~]# xenguest-install   
Would you like a fully virtualized guest (yes or no)?  This will allow you to 
run unmodified operating systems. yes  
 What is the name of your virtual machine? test1  
 How much RAM should be allocated (in megabytes)? 256  
 What would you like to use as the disk (path)? /dev/my_test_vg/xen_store1  
 Would you like to enable graphics support? (yes or no) yes  
 What would you like to use for the virtual CD 
image? /mnt/archives/released/RHEL-4/U4/AS/x86_64/RHEL4-U4-re20060802.1-x86_64-AS-DVD-ftp.iso  
   
  
Starting install...  
libvir: Xen Daemon error : GET operation failed: No such domain test1  
libvir: Xen Daemon error : POST operation failed: (xend.err 'Device 0 (vif) 
could not be connected. Hotplug scripts not working.')  
Failed to get devices for domain test1  
Traceback (most recent call last):  
  File "/usr/sbin/xenguest-install", line 396, in ?  
    main()  
  File "/usr/sbin/xenguest-install", line 360, in main  
    dom = guest.start_install(conscb)  
  File "/usr/lib/python2.4/site-packages/virtinst/XenGuest.py", line 355, in 
start_install  
    self.domain = self.conn.createLinux(cxml, 0)  
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 249, in 
createLinux  
    if ret is None:raise libvirtError('virDomainCreateLinux() failed')  
libvirt.libvirtError: virDomainCreateLinux() failed  
 
Comment 5 Jeremy Katz 2006-10-18 15:54:51 EDT
What error messages are in /var/log/xen/xend-debug.log and /var/log/xen/xend.log?
Comment 6 Josef Bacik 2006-10-18 17:07:27 EDT
from xend.log 
 
[2006-10-18 16:54:12 xend 7325] DEBUG (image:490) hvm_shutdown fired, shutdown 
reason=None 
[2006-10-18 16:54:12 xend.XendDomainInfo 7325] DEBUG (XendDomainInfo:933) 
XendDomainInfo.handleShutdownWatch 
[2006-10-18 16:54:12 xend 7325] DEBUG (DevController:143) Waiting for devices 
vif. 
[2006-10-18 16:54:12 xend 7325] DEBUG (DevController:149) Waiting for 0. 
[2006-10-18 16:54:12 xend 7325] DEBUG (DevController:464) 
hotplugStatusCallback /local/domain/0/backend/vif/6/0/hotplug-status. 
[2006-10-18 16:55:52 xend 7325] ERROR (SrvBase:88) Request wait_for_devices 
failed. 
Traceback (most recent call last): 
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvBase.py", line 85, in 
perform 
    return op_method(op, req) 
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomain.py", line 
72, in op_wait_for_devices 
    return self.dom.waitForDevices() 
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 
1596, in waitForDevices 
    self.waitForDevices_(c) 
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 
1090, in waitForDevices_ 
    return self.getDeviceController(deviceClass).waitForDevices() 
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/DevController.py", 
line 145, in waitForDevices 
    return map(self.waitForDevice, self.deviceIDs()) 
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/DevController.py", 
line 155, in waitForDevice 
    raise VmError("Device %s (%s) could not be connected. " 
VmError: Device 0 (vif) could not be connected. Hotplug scripts not working. 
 
and in /var/log/xen/xend-debug.log 
 
bridge xenbr0 does not exist!  
 
 
 
Comment 7 Jeremy Katz 2006-10-18 17:17:50 EDT
What network device does your default route go through?

This looks like you're not using eth0 and thus not xenbr0, and thus need to tell
xenguest-install to use a different bridge
Comment 8 Josef Bacik 2006-10-18 17:41:19 EDT
i'm using eth1.  I changed my /etc/xen/xend-config.sxp to have the following 
line 
 
(network-script 'network-bridge netdev=eth1 bridge=xenbr0') 
 
is that not correct? 
Comment 9 Josef Bacik 2006-10-20 11:48:25 EDT
a reboot fixed it, its now working. 
Comment 10 Baif 2006-10-27 04:43:14 EDT
What way will you use  "/dev/my_test_vg/xen_store1 " ? As a partition or a 
device in the DomU?
Comment 11 Stephen Tweedie 2006-10-27 16:46:54 EDT
So what's the status here, can we close this?
Comment 12 Josef Bacik 2006-10-27 16:51:02 EDT
yeah it can be closed, everything is working now.

Note You need to log in before you can comment on or make changes to this bug.