Bug 211255 - disk partioning: Create custom layout -> back -> Create default layout -> Reboot
disk partioning: Create custom layout -> back -> Create default layout -> Reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 02:11 EDT by Tim Mayberry
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 12:58:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log file (13.92 KB, text/plain)
2006-10-18 20:50 EDT, Tim Mayberry
no flags Details

  None (edit)
Description Tim Mayberry 2006-10-18 02:11:12 EDT
Description of problem:

I tried to install the nightly rawhide build(20061016) and when it got to the
disk partioning step I selected Create Custom Layout and then created a 100MB
boot partition. I then changed my mind and moved back to the previous screen and
selected Create default Layout. At that point clicking next brought up a dialog
stating something to the effect of "Cannot create boot partition, already
exists" and then the installer then exists and the system reboots.

Version-Release number of selected component (if applicable):

Nightly rawhide build 20061016

Expected results:

That the partition table is reset(or whatever) and installation continues as
normal(without the reboot).

Additional info:
Comment 1 Jeremy Katz 2006-10-18 10:33:50 EDT
Can you please provide the full traceback you received?
Comment 2 Tim Mayberry 2006-10-18 20:49:05 EDT
A traceback was not generated but I grabbed a spare drive and was able to
reproduce it. I've attached the anaconda.log file in case that helps.

To reproduce it I followed basically the same steps:

1. At initial partition screen select Create custom layout.
2. Click next button
3. Create a partition with the label /boot
4. Click back button
3. select "Use free space on selected drives and create default layout"
4. click next

At step 4 a popup dialog appears containing the message:

"The following mount point "/boot" is already in use, please choose a different
mount point"

"Press 'OK' to reboot your system"

So I'm guessing that the automatic partitioning wants to create a partition with
the label "/boot" but cannot because it is already in use. I was a little
confused by the message in the popup dialog as there was only one choice which
was to reboot, redo the installation and avoid repeating the procedure.
Comment 3 Tim Mayberry 2006-10-18 20:50:23 EDT
Created attachment 138848 [details]
Anaconda log file
Comment 4 Chris Lumens 2006-10-19 12:58:00 EDT
Patched to forget your partitioning changes when you go back to the parttype
screen, so you shouldn't see this anymore with post-FC6 anaconda.

Note You need to log in before you can comment on or make changes to this bug.