Bug 2112812 - [OCP 4.10] Developer catalog fails to load (on a fully disconnected cluster and on a disconnected cluster with proxy)
Summary: [OCP 4.10] Developer catalog fails to load (on a fully disconnected cluster a...
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.10
Hardware: x86_64
OS: Linux
Target Milestone: ---
: 4.12.0
Assignee: Kim Tsao
QA Contact: spathak@redhat.com
Depends On:
TreeView+ depends on / blocked
Reported: 2022-08-01 08:13 UTC by Ankita Kanekar
Modified: 2023-01-17 19:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Last Closed: 2023-01-17 19:54:07 UTC
Target Upstream Version:

Attachments (Terms of Use)
Dev Catalog snippet (74.21 KB, image/png)
2022-08-01 08:13 UTC, Ankita Kanekar
no flags Details

System ID Private Priority Status Summary Last Updated
Github openshift console pull 12011 0 None open Bug 2112812: Update registry library dependency to pick up proxy support 2022-09-01 19:07:38 UTC
Red Hat Product Errata RHSA-2022:7399 0 None None None 2023-01-17 19:54:22 UTC

Description Ankita Kanekar 2022-08-01 08:13:52 UTC
Created attachment 1900479 [details]
Dev Catalog snippet

Description of problem:

Customer is facing issue similar to https://github.com/devfile/api/issues/897

Version-Release number of selected component (if applicable):

OCP 4.10.17

How reproducible:
Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Tried working around it with ALL_PROXY but it did not help. Note because the console operator reverts changes pretty quickly testing this was a bit of a PITA

Comment 2 Kim Tsao 2022-08-03 14:39:58 UTC
I'm looking into this.  Will provide an update as soon as I can.

Comment 9 spathak@redhat.com 2022-09-09 13:48:14 UTC
Verified on a disconnected cluster with https proxy on 4.12 cluster versioned: 4.12.0-0.nightly-2022-09-07-112008
Browser version:Firefox 94

Comment 10 Christoph Jerolimov 2022-09-09 19:48:17 UTC
Please note that the related bugfix only addresses the issue that the Devfile API doesn't respect the proxy configuration and fails (after 30 seconds) on a disconnected cluster with a proxy. It still doesn't work fine on a fully-disconnected cluster.

We created the following follow-ups:

- https://issues.redhat.com/browse/OCPBUGS-270 Dev Catalog taking too much time to load in a complete disconnected cluster
- https://issues.redhat.com/browse/OCPBUGS-1105 Import a Devfile on a disconnected cluster with a proxy doesn’t work
- https://issues.redhat.com/browse/OCPBUGS-1106 Devfile Catalog and Import a Devfile on a fully disconnected cluster should fail directly instead of timeout after 30sec

If possible we will also backport all related fixes down until 4.8 when we added Devfile support in the console.

Comment 18 Christoph Jerolimov 2022-10-26 22:40:07 UTC
Hi Andy (andbartl),

TL;DR: We have two fixes for the Devfiles implemented and backported.

1. The proxy support, so that Devfiles on a disconnected cluster could get loaded. (I need to check if the import works also. I will followup on this asap.)
2. The developer catalog shows all items after 3 seconds, independent of any network call taking more time.

Both changes are available in our releases 4.12.0, 4.11.8, 4.10.37.

The proxy support is also available in 4.9.50, the UI fix to show other items after 3 seconds in our merge queue, and should be part of the next 4.9 release.

Additional fixes that are not released yet:

3. A reduced Devfile API timeout from 30 to 10 seconds is in code review.
4. We implemented a reduced timeout when loading Helm chart for the Developer catalog.

Let me know if you need more details, I will try to update this ticket from time to time until all PRs are merged.


Here is a full overview of all related issues. (October 27th)


## 1. Developer catalog fails to load => Proxy support added when loading Devfiles

Old versions of the Devfile api ignores a proxy configuration on a disconnected cluster. The new version uses the proxy configuration correctly. This doesn't help fully disconnected clusters. With this fix alone the API calls still timeouted after 30seconds. (See next two fixes!)

- 4.12.0  / https://bugzilla.redhat.com/show_bug.cgi?id=2112812 / https://github.com/openshift/console/pull/12011
- 4.11.5  / https://issues.redhat.com/browse/OCPBUGS-1030       / https://github.com/openshift/console/pull/12028
- 4.10.35 / https://issues.redhat.com/browse/OCPBUGS-1634       / https://github.com/openshift/console/pull/12040
- 4.9.50  / https://issues.redhat.com/browse/OCPBUGS-1635       / https://github.com/openshift/console/pull/12041
- 4.8     / doesn't load devfiles from the devfile registry, so no update is needed


## 2. Show already loaded catalog items after a timeout (3sec)

The first issue is that the Developer catalog and Samples catalog waits 30 second (until the Devfile network call timed-out) to show anything. This was a frontend issue we fixed. After 3 seconds we show now everything that is loaded until then. It still takes 30 second until the error is shown, at least until the timeout in the next fix is get merged.

- 4.12.0  / https://issues.redhat.com/browse/OCPBUGS-270  / https://github.com/openshift/console/pull/12019
- 4.11.8  / https://issues.redhat.com/browse/OCPBUGS-1523 / https://github.com/openshift/console/pull/12070
- 4.10.37 / https://issues.redhat.com/browse/OCPBUGS-1759 / https://github.com/openshift/console/pull/12106
- 4.9.?   / https://issues.redhat.com/browse/OCPBUGS-2008 / https://github.com/openshift/console/pull/12136 in merge queue
- 4.8.?   / planned when 4.9 is merged


## 3. Developer catalog fails to load => Reduce Devfile timeout

On fully disconnected clusters the API call to the devfile registry takes up to 30 seconds. The devfile registry calls uses now a reduced
timeout of 10 seconds. Whatever delays the network call, this will help that the UI shows an error earlier.

- 4.12.0 / https://issues.redhat.com/browse/OCPBUGS-1106 / https://github.com/openshift/console/pull/12043 / needs validation
- 4.11.? / https://issues.redhat.com/browse/OCPBUGS-2716 / https://github.com/openshift/console/pull/12186 / in code review
- 4.10.? / https://issues.redhat.com/browse/OCPBUGS-2717 / https://github.com/openshift/console/pull/12191 / in code review
- 4.9.?  / https://issues.redhat.com/browse/OCPBUGS-2718 / https://github.com/openshift/console/pull/12192 / in code review
- 4.8     / doesn't load devfiles from the devfile registry, so no update is needed


## 4. No helm chart could be loaded if one timeouted (reduced timeout per chart repository to 5 seconds)

4.12.0   / https://issues.redhat.com/browse/OCPBUGS-803  / https://github.com/openshift/console/pull/12096
4.11.8   / https://issues.redhat.com/browse/OCPBUGS-1782 / https://github.com/openshift/console/pull/12107

(internal follow up)
4.12.0   / https://issues.redhat.com/browse/OCPBUGS-2344 / https://github.com/openshift/console/pull/12141
4.11.8   / https://issues.redhat.com/browse/OCPBUGS-2515 / https://github.com/openshift/console/pull/12182

UI change to show alerts when some chart repositories could not be fetched
4.12.0   / https://issues.redhat.com/browse/OCPBUGS-1959 / https://github.com/openshift/console/pull/12200

4.8-4.10 / tbd.


Comment 21 errata-xmlrpc 2023-01-17 19:54:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.12.0 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.