Bug 211286 - anaconda tries to configure QLA4xxx HBA as an eth device
Summary: anaconda tries to configure QLA4xxx HBA as an eth device
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 186569 216985
TreeView+ depends on / blocked
 
Reported: 2006-10-18 14:31 UTC by Wayne Berthiaume
Modified: 2007-11-30 22:07 UTC (History)
8 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:00:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached is the output of the commands Jeremy requested. (17.34 KB, text/plain)
2006-10-19 14:36 UTC, Konrad Rzeszutek
no flags Details

Description Wayne Berthiaume 2006-10-18 14:31:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL 5 beta 1 M4 & M5

How reproducible:
Always

Steps to Reproduce:
1. Start a fresh install with a QLA4xxx HBA in the server
2.
3.
  
Actual results:
anaconda displays qla4xxx and NICs for the server. This is only an issue 
because the TOE NIC driver is not included in the kernel and the eth numbers 
displayed by anaconda don't match the kernel. The two HBAs get eth0 and eth1 
and the two NICs were given eth2 and eth3 by anaconda; however, when you you to 
configure the NICs they both fail. I found that by selecting eth0 and eth1 I 
was able to configure the NICs.

Expected results:
Either the QLA4xxx HBAs should not be listed as ethernet devices and only iSCSI 
hardware initiators, the qla3xxx driver is placed in the kernel so the QLA4xxx 
HBA can be used as a TOE NIC, or anaconda should not accept the QLA4xxx as 
aethernet device. 


Additional info:
An lspci() will display two devices for a QLA4xxx HBA. One is the qla3xxx which 
is a TOE NIC and the other is a qla4xxx which is an iSOE (iSCSI initiator). I 
believe QLogic reports the HBA as a network device and this will cause issues. 
anaconda needs to recognize the HBA as an iSCSI initiator and load the driver 
so it can be used to configure a boot device.

Comment 1 Jeremy Katz 2006-10-18 14:41:19 UTC
Can you provide the output of lspci, lspci -nv, and kudzu -p?

Comment 2 Tom Coughlan 2006-10-18 15:00:03 UTC
The qla3xxx networking driver was included in kernel 2.6.18-1.2715.el5 on Thu
Oct 05 2006. Please test this again in Beta 2. 

Comment 3 Konrad Rzeszutek 2006-10-19 14:36:24 UTC
Created attachment 138876 [details]
Attached is the output of the commands Jeremy requested.


Note You need to log in before you can comment on or make changes to this bug.