Bug 21131 - Solaris 8 (non-GNU make) build problem
Summary: Solaris 8 (non-GNU make) build problem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-20 17:06 UTC by Joe Orton
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-29 09:57:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2000-11-20 17:06:29 UTC
RPM build fails on Solaris 8 due to a lack of GNU make.

The generated Makefile's contain lines like:

librpm_la_DEPENDENCIES =  $(subst .c,.lo,$(DBLIBOBJS))

(from lib/Makefile.in)

The same will go for all platforms without GNU make, presumably.

Comment 1 Alan Cox 2000-11-28 17:42:00 UTC
Install gnu make on solaris first. You will also need to build libdb1 and libdb3

Alan


Comment 2 Joe Orton 2000-11-29 09:57:09 UTC
Unfortunately, this is not an acceptable solution: our customers do not have GNU
make and in some cases don't want to have GNU make.


Comment 3 Jeff Johnson 2000-12-22 15:29:46 UTC
Fixed in rpm-4.0.something, I fergit.

Comment 4 Dimitri Papadopoulos 2001-05-15 12:44:35 UTC
RPM 4.0.2 still needs gmake to build. Won't work with Sun make:

[...]
Making all in popt
make  all-recursive
Making all in intl
Making all in po
make: Fatal error in reader: Makefile, line 90: Macro assignment on dependency
line
Current working directory /home/papadopo/rpm-4.0.2/popt/po
[...]

Line 90 of popt/po/Makefile is empty and Sun's make has a problem with it:

all-yes: cat-id-tbl.c $(CATALOGS)
all-no:

$(srcdir)/$(PACKAGE).pot: $(POTFILES)
	$(XGETTEXT) --default-domain=$(PACKAGE) --directory=$(top_srcdir) \

Best regards,
Dimitri



Note You need to log in before you can comment on or make changes to this bug.