Bug 211326 - Cups cannont determine that a document has finished printing.
Summary: Cups cannont determine that a document has finished printing.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2006-10-18 18:09 UTC by Brad Settlemyer
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.5-1.fc5.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 22:31:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the file /var/log/cups/access_log (4.08 MB, application/octet-stream)
2006-10-18 18:09 UTC, Brad Settlemyer
no flags Details

Description Brad Settlemyer 2006-10-18 18:09:25 UTC
Description of problem:
Cups is unable to find the status of printed doc.  Eventually, eggcups crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.  Configure a remote printer
2.  Print a document
3.  Check document status on gnome toolbar or /var/log/cups/access_log
  
Actual results:
/var/log/cups/access_log:
Many entries like:
localhost - - [17/Oct/2006:14:03:09 -0400] "POST /printers/hp_lj1200 HTTP/1.1"
200 141 Get-Job-Attributes client-error-not-found

Eggcups won't clear the document and eventually crashes.

Expected results:
No log entries and eggcups clears the finished document.

Additional info:

Comment 1 Brad Settlemyer 2006-10-18 18:09:27 UTC
Created attachment 138812 [details]
This is the file /var/log/cups/access_log

Comment 2 Tim Waugh 2006-11-02 12:30:06 UTC
CUPS can find the status very well (try 'lpstat -h remoteserver -Wcompleted -o
hp_lj1200') -- but eggcups seems to be asking the wrong server for the status.

Comment 3 Brad Settlemyer 2006-11-02 16:05:45 UTC
No, that doesn't quite seem to work:

[bradles@riggins:~:1527]$ lpstat -h dev191 -Wcompleted -o hp_lj1200
lpstat: Unknown destination "hp_lj1200"!

Am I making a dso typo?

Comment 4 David Zeuthen 2006-11-02 19:13:14 UTC
Tim: This seems to be the same issue as RHEL5 is suffering, e.g. bug 212763.

Comment 5 Tim Waugh 2006-11-03 13:10:43 UTC
Brad: it's the hostname you want, not the queuename.

Comment 6 Brad Settlemyer 2006-11-03 16:32:02 UTC
I wouldn't be surprised if somehow this is the issue.  I simply cannot get the
status with lpstat, here is the relevant info, and some of the commands I tried:

my machine: riggins
printer host: dev191
queue: hp_lj1200

[bradles@riggins:~:1009]$ lpq
hp_lj1200 is ready
no entries
[bradles@riggins:~:1005]$ lpstat -h dev191 -Wcompleted -p hp_lj1200
lpstat: Unknown destination "hp_lj1200"!
[bradles@riggins:~:1006]$ lpstat -h dev191 -Wcompleted -o dev191
lpstat: Unknown destination "dev191"!
[bradles@riggins:~:1007]$ lpstat -h dev191 -Wcompleted -o dev191:hp_lj1200
lpstat: Unknown destination "dev191:hp_lj1200"!
[bradles@riggins:~:1008]$ lpstat -Wcompleted -o dev191:hp_lj1200
lpstat: Unknown destination "dev191:hp_lj1200"!

Beats me, I've never really had printing problems before fc5.


Comment 7 Tim Waugh 2006-11-03 16:43:40 UTC
Brad, I don't think it is the issue.  Just '-Wcompleted -o' without anything
after that will show you the jobs finished on that server; perhaps the remote
queue uses a different name than the local queue.

Please watch for updates-testing packages of (a) cups and (b) desktop-printing.
 When you have installed both of those, please re-test.

Comment 8 Fedora Update System 2006-11-07 22:25:50 UTC
Fixed in update: cups-1.2.5-2.fc6.8

Comment 9 Tim Waugh 2006-11-07 22:31:38 UTC
For FC5 the fixed cups package is cups-1.2.5-1.fc5.4.  Don't forget to also
update desktop-printing when it is released as a final update.


Note You need to log in before you can comment on or make changes to this bug.