Bug 211348 - enemies-of-carlotta conflicts with man-pages-fr
enemies-of-carlotta conflicts with man-pages-fr
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enemies-of-carlotta (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-18 15:36 EDT by Jima
Modified: 2013-01-09 23:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-18 12:15:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jima 2006-10-18 15:36:31 EDT
Description of problem:
enemies-of-carlotta contains /usr/share/man/fr/man1/enemies-of-carlotta.1.gz,
which is also provided by man-pages-fr from Core.

In my opinion, enemies-of-carlotta really should own this file, but FC6 is
already frozen, so there's really no chance of FC6's man-pages-fr dropping it. 
(The trouble being that users can install Extras packages from the installer,
but Updates isn't automatically enabled.  Ergo, if they install both
man-pages-fr and  enemies-of-carlotta, they'll get a collision.)

This is also more annoying because your copy of the man page is more current.

This could probably best be described as a workaround fix; I totally support
enemies-of-carlotta retaking ownership of the file for FC7 (where the released
man-pages-fr can be fixed).

Version-Release number of selected component (if applicable):
1.2.2-2.fc6

How reproducible:
If you're French?  Fairly.  (Wait, that sounds bad...)

Rather, if you want both man-pages-fr and enemies-of-carlotta installed in
FC6...totally reproducible.

Steps to Reproduce:
1. Install Fedora Core 6
2. Select man-pages-fr and enemies-of-carlotta
3. Not sure, an RPM conflict?
  
Actual results:
Conflict.

Expected results:
No conflict.

Additional info:
I think that sums it up.  I don't agree with the short-term solution, but it's
probably what needs to happen.
Comment 1 Jesse Keating 2006-10-18 15:42:06 EDT
Please note that the conflict WILL kill the installation where your only choice
is to reboot.  Theoretically this could happen with ugprades too, and then your
only choice is to reboot a half upgraded system.
Comment 2 Ralf Ertzinger 2006-10-18 15:49:19 EDT
This is known and was reported by me in #208826 against man-pages-fr. According
to the maintainer this is fixed in man-pages-fr-2.39-5.fc6.
Comment 3 Jesse Keating 2006-10-18 15:55:34 EDT
Unfortunately the maintainer never asked for that build to go into FC6, since it
was done after the freeze, and thus it didn't make the final FC6 cut.  So the
problem still exists.
Comment 4 Ralf Ertzinger 2006-10-18 16:13:37 EDT
And what do you want me to do about that?
I could remove the man page from the e-o-c package, but that would lead to a
time frame where no french man page is available for the package at all.
On the other hand, of the 5 people on this planet who actually use e-o-c, at
most one can be able to understand french, so....
Comment 5 Jima 2006-10-18 16:18:03 EDT
Can anyone think of a not-too-hacky way to rename the file so it doesn't
conflict, but it's not too terribly difficult to find?
Comment 6 Ralf Ertzinger 2006-10-20 13:13:09 EDT
I've built e-o-c-1.2.2-3 which excludes the french man pages for the time being.

Note You need to log in before you can comment on or make changes to this bug.