Bug 211352 - gnome power manager doesn't follow obey critical power level setting
gnome power manager doesn't follow obey critical power level setting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 15:47 EDT by Trever Adams
Modified: 2013-03-05 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 20:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2006-10-18 15:47:08 EDT
Description of problem:
I have an HP dv 6000 series laptop. I have told gnome-power-manager to hibernate
on critical power level (not sure what that is, I have only see the warning a
few times).

On multiple occassions now I have had the machine shut off due because power
failed, not because it went into hibernation.

Version-Release number of selected component (if applicable):
2.16.0

How reproducible:
Always. I just got a critical power (2%) warning. No hibernate. I am typing this
still.

Actual results:
No hibernation.

Expected results:
Hibernation should happen.

Additional info:
Comment 1 Trever Adams 2006-10-18 15:57:20 EDT
Ok, make that it doesn't work for me consistently. I just got my first hibernate
out of it at 1% of battery life. As I have said, frequently it just dies because
the battery is completely dead.
Comment 2 Richard Hughes 2006-10-18 16:05:51 EDT
g-p-m works on time remaining rather than percentage charge. It could be your
battery is being liberal with the truth. To test this, try setting
/apps/gnome-power-manager/use_time_for_policy to false.
Comment 3 Trever Adams 2006-11-23 07:47:45 EST
I think this is the case. I am beginning to test the option now.
Comment 4 Trever Adams 2006-11-24 02:21:28 EST
My estimates of time bounce as high as 40 hours on charging (with the real being
about 40 minutes). Similar things happen with decharging. Is it possible to put
in a sanity check for the decharge (power consumption) so that if the time goes
up, it ignores the value until it is lower than the last "valid" value. The one
exception is when the machine gets plugged in. It should then allow the time to
change.

Is this a good solution? I suggest this as this seems to be likely to happen on
any AMD dual core Turion 64 with AMD Power Now enabled.
Comment 5 Richard Hughes 2006-11-24 16:50:58 EST
Hmm. I don't think we should fix this at the g-p-m level, more so at the HAL
level. How comfortable would you be trying CVS HAL for me? Thanks.
Comment 6 Trever Adams 2006-11-24 18:15:37 EST
Yes, I forgot that HAL does most of the actual work for many things like this.
Can you give me a HAL that will work in FC6? If so, I would be happy to test out
things for you. I just can't take the entire computer to rawhide.

Can that be done?
Comment 7 Richard Hughes 2006-11-26 17:58:38 EST
I think you want to look at the utopia repo, but beware it also installs very
new versions of pm-utils and other core-system stuff so if it breaks, you get to
keep both bits[1]. :-)

Richard

[1] seriously, you can "rpm -e --no-deps x && yum install x" to get back to the
FC6 stock versions if things don't work out.
Comment 8 Trever Adams 2006-11-27 05:30:53 EST
Ok, I do not know of the utpoia repo. Who does it? What is it? And I am
realizing that my fix only solves about half the problem. It won't cause a
hibernate in 50% or more of the situations.
Comment 9 Richard Hughes 2006-12-09 15:07:53 EST
http://people.freedesktop.org/~hughsient/fedora/utopia.repo

Caveat emptor.
Comment 10 Trever Adams 2006-12-10 04:25:30 EST
I have not been able to get this to install. It wants hal-info which isn't
apparently in FC6 nor in rawhide nor in utopia.
Comment 11 Trever Adams 2006-12-20 05:08:37 EST
This may fix some of it, but it is not a complete fix.
Comment 12 Trever Adams 2007-09-23 20:56:26 EDT
I am no longer able to duplicate this bug. Some of it turned out to be that my
"smart" battery is actually quite ignorant.  Closing.

Note You need to log in before you can comment on or make changes to this bug.