Bug 211355 - [kexec-tools] Possible use of direct IO while copying the vmcore
[kexec-tools] Possible use of direct IO while copying the vmcore
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On: 211366
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 15:52 EDT by Vivek Goyal
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.101-163.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 09:32:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to restrict pagecache useage in initramfs (636 bytes, patch)
2006-10-19 13:07 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Vivek Goyal 2006-10-18 15:52:11 EDT
Description of problem:
Can you use direct IO (option provided with dd) while copying the dump to local
disk. It would avoid caches and chances of OOM killer triggering during dump
copying operation are less.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Neil Horman 2006-10-18 16:22:43 EDT
unfortunately, busybox cp and dd applets do not currently support the use of
O_DIRECT in thier operation.  However it appears fairly simple to add support
for  direct I/O to busybox. I'm opening a feature request on busybox to see if
we can get this in, and if so, we can fulfill this request. 
Comment 2 Neil Horman 2006-10-18 20:19:39 EDT
Note to self: While the idea of adding direct I/O to some busybox utilities is a
good idea, it just occured to me that we may not need it to do what we want
here.  If the goal is to avoid oom kills, we may be able to do this through
various vm tunings.  for instance by setting the dirty_backround_ratio and
dirty_ratio very low, we can probably severely limit how much memory is used in
pagecache.  There may also be a setting to exlicitly disable oom killing.  I'll
look into these items in the AM.
Comment 3 Neil Horman 2006-10-19 13:07:19 EDT
Created attachment 138883 [details]
patch to restrict pagecache useage in initramfs

patch to tightly restrict pagecache filling in initramfs
Comment 4 Neil Horman 2006-10-19 13:18:14 EDT
vivek, could you please try this patch out? It tunes the vm sysctls to help
limit the amount of memory that can be used by pagecache.  If it works well
enough, we may not need to use direct I/O to stem oom kills.  Thanks
Comment 5 Neil Horman 2007-01-18 09:32:56 EST
I'm closing this as CURRENTRELEASE, since I've already implemented this.  If I
get the chance, I'll look into submitting a patch to busybox to enable directIO
on its dd applet.

Note You need to log in before you can comment on or make changes to this bug.