Bug 21136 - NFS file corruptions with kernel-2.2.16-3
NFS file corruptions with kernel-2.2.16-3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-20 13:05 EST by frichard
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:47:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NFS v2/v3 patch from Trond/DHiggen (710.91 KB, patch)
2000-11-20 13:09 EST, frichard
no flags Details | Diff

  None (edit)
Description frichard 2000-11-20 13:05:45 EST
First off, I have a fix for this.  Basically, you need to add the
Trond/Higgin NFS patches to the Kernel SRPM and recompile.  I'm happy to
provide you with my `spec' and `patch' file if you want them.  Just send me
e-mail.

Please try to put this patch into an up-coming `errata' kernel release.  We
had more problems with certain NFS corruptions after upgrading to the
current errata kernel.

The situation is this: I have a program that generates large files [100Meg]
and performs `fseek's to re-write data somewhere back in the file.  Then
there's a read program which verifies the data.  Both programs are
available on request.

Here's a table of the results on various NFS client/server combinations:

    NFS Client      NFS Server      Results
    ========================================================
    RedHat 4.2      Solaris 2.6     Works fine
    RedHat 6.1      Solaris 2.6     Works fine
    RedHat 6.1      RedHat 6.2*     Works Poorly ***
    RedHat 6.1+     RedHat 6.2+     Works OK (fewer corruptions)

    RedHat 6.1+     Solaris 2.6     Broken (any "fan in")
    RedHat 6.2+     Solaris 2.6     Broken (any "fan in")
    RedHat 6.1+     Solaris 2.6+    Broken (any "fan in")
    RedHat 6.2+     Solaris 2.6+    Broken (any "fan in")

Notes:
    RedHat 6.1          "Vanilla" RedHat 6.1
    RedHat 6.1+         Updated RedHat 6.1 (kernel 2.2.16)
    RedHat 6.2+         Updated RedHat 6.1 (kernel 2.2.16)
    Solaris 6.2         "Vanilla" i86 Solaris 6.2
    Solaris 6.2+        i86 Solaris 6.2 + patch cluster

    ***                 The corruptions occurred about %40 of the
                        time and required 10 clients to be writing
                        to the server at the same time.
Comment 1 frichard 2000-11-20 13:09:40 EST
Created attachment 5563 [details]
NFS v2/v3 patch from Trond/DHiggen
Comment 2 frichard 2000-11-20 13:13:27 EST
I also updated these packages incase I ever want to try NFS v3 (note that all my
tests were with v2).  The funny version numbers are because I had to hack a few
package spec files to build under RedHat 6.x (I'm happy to send specs if you
want them):

	losetup-2.10m-6.1
	mount-2.10m-6.1
	nfs-utils-0.2.1-2mdkfr
	nfs-utils-clients-0.2.1-2mdkfr
	am-utils-6.0.4s5-8fr

Note You need to log in before you can comment on or make changes to this bug.