Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Mirroring complete ansible galaxy fails with the following message:'NoneType' object has no attribute 'get'
Issue has been resolved in upstream: https://github.com/pulp/pulp_ansible/pull/815
Can we have the fix in downstream satellite 6.11 or 6.12?
Version-Release number of selected component (if applicable):
RedHat Satellite 6.11
How reproducible:
Complete Ansible collection sync fails.
Verified in 6.12 snap 6.0
Complete mirror of Ansible Galaxy syncs successfully.
Steps to Reproduce:
1) Create a custom repo with https://galaxy.ansible.com as the upstream repo url
2) Set Settings > Content > Download rate limit to 5
3) Sync the repo
Expected Results:
The repo syncs successfully.
Actual Results:
The repo syncs successfully.
Notes:
If you do not set the rate limit in step 2 you can get "Too many requests" errors during the repo sync.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (Important: Satellite 6.12 Release), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHSA-2022:8506