Bug 211396 - fencing causes loss of quorum after node removal
Summary: fencing causes loss of quorum after node removal
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cman   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-18 21:44 UTC by Lenny Maiorani
Modified: 2009-04-16 20:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 08:21:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lenny Maiorani 2006-10-18 21:44:47 UTC
Description of problem:
after removing a node from a 3 node cluster, fencing either of the remaining
nodes causes loss of quorum

Version-Release number of selected component (if applicable):
RHEL4 Update3

How reproducible:
always

Steps to Reproduce:
1. start with 3 node cluster, remove 1 node completely
2. instigate a fence operation on either of the remaining nodes
3. fencing causes loss of quorum
  
Actual results:
loss of quorum

Expected results:
since it is now a 2 node cluster, quorum should not be lost

Additional info:
graceful shutdown of one of the remaining nodes by stopping cman does not cause
loss of quorum

Comment 1 Christine Caulfield 2006-10-19 08:21:18 UTC
If you remove a node from a 3-node cluster you don't get a two-node cluster
unfortunately. 

What you actually have is a 3-node cluster with one node removed and quorum
artificially lowered.

The two_node cluster (as in the cluster.conf key) is a special case in cman and
requires a full cluster reboot to enable/disable the features that mean it can
continue with only a single node active.

If you need a 3 node cluster to keep running with only one active node you will
need to configure a quorum device using qdiskd.



Note You need to log in before you can comment on or make changes to this bug.