Bug 211406 - /etc/X11/xinit/Xsession relies on switchdesk
/etc/X11/xinit/Xsession relies on switchdesk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 18:02 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.0.2-13.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 18:32:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-10-18 18:02:16 EDT
Description of problem:

the kde and the twm cases rely on switchdesk to be present 
to be launched correctly. To be more robust in the kde case
(and in the twm case switchdesk has allready been tested)
I think the following could be used:

    kde|kde1|kde2)
       if [ -x "$SWITCHDESKPATH/Xclients.kde" ]; then
           exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH $SWITCHDESKPATH/Xclients.kde";
       fi;
       exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH startkde"
       ;;

    twm)
        # fall back to twm
       exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH twm"
       ;;

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kristian Høgsberg 2006-10-23 14:36:18 EDT
We already check the existance of a switchdesk file earlier in the script, so we
should just take out the switchdesk code and launch startkde or twm directly. 
Just built xorg-x11-xinit-1.0.2-13.fc7 in rawhide with this patch:

@@ -62,11 +57,11 @@ case $# in
        exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH gnome-session"
        ;;
     kde|kde1|kde2)
-       exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH $SWITCHDESKPATH/Xclients.kde"
+       exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH startkde"
        ;;
     twm)
         # fall back to twm
-       exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH $SWITCHDESKPATH/Xclients.twm"
+       exec -l $SHELL -c "$SSH_AGENT $DBUS_LAUNCH twm"
        ;;
     *)
        # GDM provies either a command line as the first argument or

As for kde1 and kde2, switchdesk should provide symlinks if those cases are
still relevant (probably not in rawhide).

Once rawhide starts pulling from fc7 this change should be available there.
Comment 2 Patrice Dumas 2006-11-21 18:32:19 EST
This seems to be fixed, closing RAWHIDE. The need to have 
Xsession.d/Xsession.$wm script for any desktop should 
certainly be added to the guidelines.

Note You need to log in before you can comment on or make changes to this bug.